Engine 1986 5.0-GT- Idling/bucking Problems

QuickFox86

Member
Sep 22, 2020
10
7
13
17
Mesa
Hey guys. So I'm having running problems with my '86 GT. Sometimes the car runs great, but sometimes it will have a bad idle and buck really bad when you attempt to drive it. It also sounds like it's backfiring sometimes. I know this is probably an ignition/timing issue, or maybe I have a vacuum leak somewhere. It also might be a TFI module, but I am not sure. Anybody have any suggestions? Thanks.
 
  • Sponsors(?)


General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
21,140
7,369
203
polk county florida
Many things come to mind as possible causes but rather than poke here or jab this do this checklist step by step,
 
  • Useful
Reactions: 1 user

QuickFox86

Member
Sep 22, 2020
10
7
13
17
Mesa
Many things come to mind as possible causes but rather than poke here or jab this do this checklist step by step,

Ok I'll run through it. Thanks.
 

Willybill32

But at least it's tight!
Jul 16, 2019
318
130
53
Lexington, KY
Hey guys. So I'm having running problems with my '86 GT. Sometimes the car runs great, but sometimes it will have a bad idle and buck really bad when you attempt to drive it. It also sounds like it's backfiring sometimes. I know this is probably an ignition/timing issue, or maybe I have a vacuum leak somewhere. It also might be a TFI module, but I am not sure. Anybody have any suggestions? Thanks.
So, is your '86 completely stock? If not, what modifications?
 

QuickFox86

Member
Sep 22, 2020
10
7
13
17
Mesa
As far as the engine goes I know the speed density system has been replaced with a mass air system, and the EGR has been deleted, as well as aluminum heads, msd box, and a tubular intake manifold off a 1st gen lightning.
 

Willybill32

But at least it's tight!
Jul 16, 2019
318
130
53
Lexington, KY
As far as the engine goes I know the speed density system has been replaced with a mass air system, and the EGR has been deleted, as well as aluminum heads, msd box, and a tubular intake manifold off a 1st gen lightning.
Do you have an aftermarket cam by any chance? I have an original '86 converted to mass air, plus E303 cam, aluminum heads, roller rockers, 24lb injectors, equal-length headers, etc., as well as deleted smog pump and EGR. At low speeds (under 1,500 RPM) I frequently get bucking, which I'm told is likely the cam. But my idle is great. I did take it to a tuner for some work.