1994 5.0 mystery wiring connector

no_fox_given

New Member
Dec 22, 2016
7
0
1
27
Hello all, first time poster after owning this car for about 1.5 years now, bought the car already heavily modded. I've finally found a wiring connector that I am unable to find in any wiring diagram, FSM, EVTM, forum post or google search...

The connector is on the body harness, behind the passenger headlight under the intake. Wire colors I THINK are PNK/LTBLUE, GRN/YEL, BLUE/YEL, BLK.

Hopefully someone can ID this for me! So far the only things I think it could be are evp, something related to abs, or ccrm. Thanks in advance.
 

Attachments

  • Sponsors(?)


jozsefsz

5 Year Member
Aug 11, 2013
1,114
255
114
48
Cleveland OH Area
Well, it doesn't look like an abs module connector, nor does it look like anything A/C-related, and the CCRM just has one big screw-on connector. The evap stuff is up under the fender. The only other connectors in that area are related to headlights, the coolant bottle, and the MAF / Air Temp sensor. And that connector doesn't appear to match any of those. In fact I'd say just looking at the connector's innards that it doesn't look all too "Ford" at all.

I'd have to guess something aftermarket (I could be completely wrong but definitely haven't come across that connector personally on my 95). And with the wires appearing melted as they are, something reasonably high-amperage (some aftermarket fog-lights or colling fan maybe?) Maybe one of the folks who has done a full wire-tuck in the engine-bay could better help.
 

no_fox_given

New Member
Dec 22, 2016
7
0
1
27
This was @BlueOvalStangGT's old car, which I believe he said had a procharged setup at one point... so aftermarket cooling fan sounds likely if this is not a factory connector of any sorts.

The problem I have with that theory is that the wiring is too good to be aftermarket. I'll have to get pics of the rest of the engine bay area where it is, but it was wired into the body harness with seemingly original tape, and where the wires are in the connector are period-correct looking for oem.

Again, pics of the area where the connector is would help out way more than me trying to describe it, but it sat right on top of the framerail under the intake. Other things that I could think of that might've been in that area would be related to the smog pump, EGR, factory fog lights. Don't think it's the coolant bottle because that's right next to the main CCRM connector. my MAF and IAT are both in very different spots too.

I'll update with more pics of the area once I get home today. Thanks for the input @jozsefsz!