2001 mustang gt Kenne Bell supercharged.

Aiello

Member
Jan 30, 2021
7
2
13
65
West Palm Beach Florida
Hello everyone. My mustang has had an intermittant crank no start, began by giving it a shot of starting fluid, it started and kept running like normal,fuel pressure was between 30-35 like normal. Suddenly fuel pressure dropped to 0 and she started to stall, blipped the gas and went back to normal pressure. Shut everything down and left it until the next day, tried to start, no fuel pressure could hear relay click under front right fender, had 12V into and out of the inertia switch. Was going to bypass FPDM and jump the fuel pump, upon disconnecting the connector from the FPDM, noticed green corrosion on all the male pins sprayed all with electrical cleaner, cleaned up nice, sprayed the female connectors just for good measure. Found same green corrosion on the tank connector all pins, cleaned everything. Started up the car an it ran fine. Going to leave it overnight and see what happens tomorrow. Any opinions gladly accepted. Thank you.
 
  • Sponsors(?)


StangNet created a new car social app called knowmoto! Add your Mustang or post a photo in the knowmoto app and enter for a chance at a $100 gift card from LMR. Click the LMR Logo for more about the knowmoto Mega Thread!

Aiello

Member
Jan 30, 2021
7
2
13
65
West Palm Beach Florida
UPDATE: Car has been starting since cleaning FPDM Connectors and Connectors to fuel tank. One thing I noticed while cranking, fuel pressure will drop from 30PSI to 20 PSI until it starts then go back up to 30PSI. Don't know if that's normal, never paid attention before to see if it always did that. Opinions please.