332 code, car running funny

KamiKaziDK

Member
May 16, 2005
555
0
17
Mesa, Az
When cruising at a constant speed my car has been stuttering and running funny, almost like a miss, but I know I don't have one. I ran the codes today and I got a 332 code for "Insufficient EGR flow detected" in my continuous memory. looked it up on the forum, but nobody else has driveability problems with the code....any thoughts?
 
  • Sponsors(?)


Chythar

15 Year Member
Aug 26, 2004
2,206
40
98
48
West Los Angeles, CA
When you're at part throttle, the computer lets in exhaust gas to be re-burned, thus making the exhaust a little cleaner. It's carefully metered, and the computer makes adjustments to compensate for the extra air flow. If the EGR sensor or valve aren't working right, the wrong amount of exhaust is let in and the engine will run rough. The sensor is sold separately from the valve (and is cheaper), so I'd recommend replacing the sensor first and see if that fixes the issue.
 

KamiKaziDK

Member
May 16, 2005
555
0
17
Mesa, Az
Thanks Matt. Nice explanation. And yeah, it's only at partial throttle, when I mash it, you can't feel a thing, forgot to put that in the initial post
 

HISSIN50

"How long does it take to get help in here?
SN Certified Technician
Nov 29, 1999
31,179
26
129
Before replacing anything, ensure the vac lines and wiring are intact. Make sure the position sensor voltage changes if you open the EGR valve (a hand pump can be used to open it with the Key-on, car off).

FWIW, if the code is present, the EEC should have shut off your EGR function (the allowing of extra timing and less fuel due to the inert gasses that should have been present).