Progress Thread 89 hatch hydroplanedrifterweldeddiff thread:

  • Sponsors(?)


Rdub6

Mustang Master
Dec 29, 2017
1,708
1,244
123
Long Island, NY
Does still show the path or circuit needs to be complete to work properly though. Which based on my understanding my circuit is not complete. B/c no starter ground or no ground from engine to firewall/strut. My ground is batt to frame to engine block. I need engine block back to frame. Im thinking. Which is dangerous in of itself.

Yeah, was just trying to give you a better understanding of how the electricity flows.
There’s a pretty good thread by jrichter on putting the battery in the back. It has diagrams of exactly how the wiring should be. Might want to take a look at that.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Hooker 1 left me stranded. Lol. Was getting an inspection today, 2nd try, since i put a blinker bulb in, and flasher relay and had bkinker working. Oh but it didnt work when lights were on. Apparently i put wrong bulb in. It was a blinker bulb, now, either the the bulb is new bulb is funky or it needs to be exact same part # as old one. Not just ultra similar basically the same?

So car randomly died a couple times. Then happened backing out of drive way later on.

Then died randonly after drifting plenty running good, just got moving from a stop sign, and just poops out. So now i gotta let it cool for 30 minutes before even trying b/c sally doesnt like to start hot.

Just turns over.. nicely (b/c of that new starter lol) but no runny. Will check fuel pressure tomas. And spark.

Any guesses? Ima go broad with either fuel or spark/electrical.
 
Last edited:

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
^^^ Fixed that issue. PCM relay. Rusted into 20 pieces. Lol. What? Thats too crazy when i saw that. That had to be a fire hazard.
IMG_20200928_113505.jpg

IMG_20200928_113516.jpg


Anyway, update is, finally got off my ass and added 2 grounds. The head to firewall, and 1 from motor to frame. No pics cause boring. Might of helped my hot start issue. Bearly. Not enough though.

Will re do the ground from rear battery to motor next wknd. (Copper 1/0) Bet it takes care of the hot start issue. Now, it just sounds kinda weak when starting hot, but has enough to start it w/o blowing the fuse. Tbh, im lazy might just go to circuit breaker for now. If it gives me problems then re do the ground.

I think that CCA 1/0 is literally just BEARLY over the threshold of current for it at X tempature.

Car ran stronger than ever tonight. Did a couple laps. Few variables: dead tires, no grip so esier to slide, 68 out here vs. 85. Intaketemps and concrete slicker. No top end miss at all. Might be the new PCM relay, could be the grounds.
 
Last edited:

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Mod of the day:. Got this 03 cobra bumper on. Its crazy how good it lined up at the fender well. Just by chance. Ill get those pics tomas.

Patches my hatch this week also i had bought a good hatch, and realized the connectors were different so didnt screw with it. Just gonna take the window trim and give it back to the guy i bought it from.
Cut out most all the rust. More pics of this finished tomorrow.
IMG_20201005_164732.jpg
IMG_20201005_122834.jpg
IMG_20201005_164725.jpg
IMG_20201005_164739.jpg
IMG_20201007_132226.jpg
IMG_20201007_134221.jpg
IMG_20201007_184230.jpg
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Why you say?

Looking forward to doing the wrap soon and getting it 1 fresh color. Just gotta cough up the dough first. Lol.

Just found a saleen rear bumper cover local for $80, gonna have to go buy that and get it on.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
17,486
5,637
193
polk county florida
Why you say?

Looking forward to doing the wrap soon and getting it 1 fresh color. Just gotta cough up the dough first. Lol.

Just found a saleen rear bumper cover local for $80, gonna have to go buy that and get it on.
A member here swapped a cobra bumper on a mustsng, don't have time to look, someone will kick it up.
 

Noobz347

Stangnet Facilities Maint Tech... Er... Janitor
Admin Dude
Jan 4, 1985
29,149
10,949
224
Box behind Walmart
www.stangnet.com
A member here swapped a cobra bumper on a mustsng, don't have time to look, someone will kick it up.


See? LoL Only now do you glimpse into the Dark Side. :O_o:

Most folks in PM: "What do you mean you don't remember the paint code that someone used on the brake caliper that they took from M1 Abrams? How could you possibly forget that??"


Me: :oops:



Their next message: Can you just gimme a link to the thread then?



Me: :oops:


Moderators: "Let's go pick on Mike for a while then find someone to ban."


Me and Mods: :rabble:
 
  • Haha
Reactions: General karthief

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
^^. Lol.

What hatch did you buy that isn't going to be a bolt on plug and play affair?

You tell me. Lol. No, i dont know. Ill have to ask the guy what yr car it was off of. Apparently some years have 2 barrel connectors and mine had 1 barrel and a square plug.

That someone was me...lol.

My front bumper and car color are identical...only I bonded mine on instead of the riveted look. That's what forums are for. I likes it a lots.
I saw it. I was thinking it was you. Looks good. Ya im super stoked on the look too. I countersunk the holes i drilled and since the bumper was pretty thick and avoided the washers. So got the bolts flush. Ima wrap over em. I saw some ppl make a bracket for the fender well part, but mine really firmed up once i got the bolts into the metal part of the fender. Its good as is.
 
  • Like
Reactions: 90sickfox

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Few more pics:
IMG_20201008_102108.jpg
IMG_20201008_102122.jpg
IMG_20201008_102154.jpg
IMG_20201008_102215.jpg

Bout to put on couple pieces of molding then finish sand and prime the hatch. Got more "cool" (to me) stuff coming. Carbon hydro dipping a few things. Already failed twice on the cowl cover. I think my activator was old/bad. Cheap film, bad water temp.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Hatch primed up. Gotta fix a rust spot on door, by window molding trim thing, then ill order some teckwrap (only clue im giving lol)
IMG_20201008_190342.jpg

Dont know what that is in the pic, btm left side by wing/window corner but its good and smooth there. Better than pic.

Ok, maybe its a small divot/imperfection, and it looks terrible in the pic. Lol. Shows up more than i thought.
 
  • Like
Reactions: Rdub6