Progress Thread 89 hatch hydroplanedrifterweldeddiff thread:

Boostedpimp

15 Year Member
May 8, 2003
1,052
355
114
NJ
How come you didn't zip tie the power wire to the lower bar so it's out of sight somewhat?

And yeah driving without a front swaybar turns the driving experience into total crap so be careful
 
  • Sponsors(?)


Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
B/c the front headlight harness is going to go right there also/laziness.

So wired up the fans. No go. Wouldnt turn on. So going to test them and see if they even work. I have power for the relay going to the pos+ on starter solenoid. Then the fans are hooked up to each power wire coming out of the relay. Everything wired correctly per directions. Just used the sketchy 14awg out the relays, connected to 10ga. Lol. Sketchy? Maybe, but they should at least turn on.

Put coolant in radiator, no go. Lol. Found a small leak
 
  • Surprised
Reactions: General karthief

Rdub6

Mustang Master
Dec 29, 2017
1,708
1,244
123
Long Island, NY
B/c the front headlight harness is going to go right there also/laziness.

So wired up the fans. No go. Wouldnt turn on. So going to test them and see if they even work. I have power for the relay going to the pos+ on starter solenoid. Then the fans are hooked up to each power wire coming out of the relay. Everything wired correctly per directions. Just used the sketchy 14awg out the relays, connected to 10ga. Lol. Sketchy? Maybe, but they should at least turn on.

Put coolant in radiator, no go. Lol. Found a small leak

when is your front end going to be this accessible again. You might as well do it right, and make it look right/ professional.
And yeah, I’d say 10g to 14g is sketchy, but if not sketchy...... it’s just not right! Do it once, do it right is how I look at things now.
 
  • Agree
Reactions: General karthief

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Ya, it could be cleaner, iono, i didnt really want it low to keep it out of water. I will ziptie it under the headlight harness once i bring that in tho.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Threw a power steering pump in i got from a local foxbody guy/collector. Power steering back, so thats great. Saves me from rack swap, shaft, work for now... First time i made it out to his house to buy something finally. Cool ass kat.

So he'se got like 30 foxes parted out. Lol. He also has a vert saleen w/ 18k miles. 7 made that year. (WTF!) A hardtop saleen with low miles. Like pristine, dude keeps that one in a plastic bag. Lmao. And like 6 other personal foxes. 79 pace car, 84 turbo capri, svo, 85 notch (gonna coyote swap it, has the 2016 parts car for it) 2, 93 cobras. Etc.. He might be the most hardcore fox guy in the country. Lol.
 
  • Like
Reactions: General karthief

7991LXnSHO

Now I want a 10 year badge
10 Year Member
Sep 1, 2010
3,175
611
164
Kearney, NE
When you are sliding the car around and working the power steering hard, does PS fluid leak out the cap, especially the little vent hole? If so, what do you do about it?
I’ve seen duck or gorilla tape around the top of the tank neck and cap on some racing Mustangs. If I go hunting orange cones in a parking lot, I’d rather have a better solution to not have PS fluid leaking in the engine compartment or pavement.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
17,486
5,637
193
polk county florida
We had a camaro in the shop last year, he had a nipple in the top of his ps cap with a hose that ran to the fender with a small breather on it :shrug:
The owner said he did track days at Sebring.
 
  • Useful
Reactions: 7991LXnSHO

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Hmm, i have'nt noticed that issue. It might, if it does its been very minor and never caught my attn. Actually, ima say no. My rack leaks like bearly when car is on the ground. More so if jacked up. ... point being i keep the cap clean so i can put fluid in it and never notcied fluid on cap.

I put on that PS pump, son of a bitch leaks. Very Minimal slow drip, yoi k ow, where the 2 halves if the pump seal. i ran like 80% ATF type F, and 20% prestone PS fluid and 10% lucas oil heavy duty motor oil stabilizier cause it was thick i was like this looks good. (Alrdy had some in cabinet) Lolol. That steering is featherlight!
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Well, appears you are right. How the hell i never noticed it before i dont know. Fluid is coming out of vent hole. So ya, ill just get some small tube, drill the hole bigger so it presses in, and run hose to overfill bottle. (That i need to put on... ziptie on lol)
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
17,486
5,637
193
polk county florida
Do it right, get a threaded nipple, drill a hole, use some silicone on the threads to seal it, run a hose above the pump to a catch can of some sort with a breather so it is vented,, just keep it as far above the pump as possible.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Put a new starter in. It starts faster. But the hot start issue still persists, apparently. Also ran the computer ground to the battery. Just cuz that needed to be done.

Also had my old 3k rpm cut out problem arise again. The new fuel pump did fix that for the last 6 months.

The ear was broke on my old starter, and the internal ms didnt look much better. Gear teeth were fine though.
20200905_145703.jpg
20200905_180620.jpg

Was all excited b/c rain came and thought i was going to get to drift. But failed when the 3k cut out arose. Smh. Lol.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
So i got it up to temp. Drove around 20 minutes. Came back, tested starting hot. Worked fine.

Went to gas station, let it sit for 5 minutes, then just bearly turned over.. and had to stop before it blows the stupid fuse that someone thought was a good idea to put on the pos+ battery cable. More over engineering from some unqualified source im sure.
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
Good idea again. Will do. Only + wire right? Or will neg. Carry voltage also?

The 3k miss went away once it dried up. So im thinking something got wet, everything leads to a short sonewhere imo. Went and got a couple laps in even. Woohoo.

I pulled up to house and my windowjist started getting stuck near the top, but when i press up button, i noticed the radio cut out also. Lol. Did end up working. Strange though.

I hate electrical gremlins. Damnit.

-voltage drop test
-check ign switch plug
-check engine strap.

My to do list for now.

So if i get voltage drop, what does that mean?
 

Foxslider

im not that much of a idiot
Oct 25, 2019
480
139
53
33
Houston, TX
You know i go by feel and thought. My gut says its a resistance issue once its hot. Im not an electrician obviously. Ie: i feel like its a grounding issue. I dont know.