Electrical 89 Lx led brake lights stay on, go off with push of clutch pedal.

CoyoteFive0

Member
Sep 19, 2021
6
3
13
48
Northwestern. Illinois
Hi all,
1989 Lx conv, I've been running led tail lights from Easy Performance and have a weird issue. Sometimes when driving car the brake lights stay on, now weird part is clutch pedal turns them off when pressed just a little. Anyone know if the clutch switch is related in any way to the brakes?

Thanks for any advise you can offer

Chad
 
  • Sponsors(?)


Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
38,935
14,837
224
Massachusetts
They are connected through the cruise control as the CC monitors the circuit. The clutch pedal has a switch that breaks the loop to the cruise module.

Reason they are glowing is because LEDs regular very little voltage to activate.

Does your cruise work, and do you want it to continue to work?
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
38,935
14,837
224
Massachusetts
Unplug the clutch switch and that should solve the problem.

The switch is located on the right side of the pedal box where the clutch quadrant is. It has a black sheathng over the wiring. Unplug it and tuck the connector and that should solve it. Cruise won't work again though.

Looks like this. It's not the same as the clutch switch on the clutch pedal arm side


I also believe unplugging the cruise control amplifier will also achieve the same result. The box is located under the dash bolted to the driver's door jamb area and is a yellow box. Two plugs. One to the servo and the other to the body wiring.

1632143637680.png
 
Last edited:
  • Winner
Reactions: 1 user

CoyoteFive0

Member
Sep 19, 2021
6
3
13
48
Northwestern. Illinois
I didn't see any separate switch on clutch pedal area besides the safety switch. Could they have used the safety switch to interact with the cruise? I unplugged the amplifier which I did find under the dash. It's raining today here, but I'll get it out and see if same issues arise. My car is an early 89 had an 85mph speedo instead of the 140, no anniversary horse emblem on dash and a few other things don't match the 89 cars as much as previous years.
Thanks again for the help.
 

foxbodybill89

Active Member
Jan 19, 2020
119
55
38
33
Sioux Falls, SD
Wiring a load balancer resistor into each taillight circuit will make lights and cruise work correctly without unhooking or changing any of the switches.
 
  • Happy
Reactions: 1 user

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
38,935
14,837
224
Massachusetts
I assume he had a coyote swap car based on the username. I don’t think he would be able to get the factory cruise working if he wanted to.
 

CoyoteFive0

Member
Sep 19, 2021
6
3
13
48
Northwestern. Illinois
Thanks for all the great solutions. I am just happy knowing that I can get the tail lights working properly. Cruise control hasn't worked in years as the cable mount on throttle body broke awhile back. I have a 2017 GT and an 89 Lx 50 conv.
 
  • Like
Reactions: 2 users