Electrical 90’ lx dies while driving or idling randomly please help

Black_Mare

New Member
Dec 22, 2018
10
0
1
29
South florida
Hey guys, need help please, been bangin my head over this issue for the past week, the issue is the car randomly dies, loses spark, all accessories will stay on, tach drops to 0, if I turn the key off and back on it will turn back on most the time, sometimes I have to cycle the key twice 3 times even, I have replaced the following:
New motorcraft tfi
New motorcraft pip
New msd coil
New starter relay
New ignition switch
New cap and rotor
New fuel pump relay
New eec relay
New msd wire from coil to dizzy

When the car dies it doesn’t have spark, but I got 12 volts to the coil, 12 volts at ignition switch, 12 volts at injectors, 12 volts at the plug for the tfi, I do not have a noid light to test pip but again I have 12 volts at injectors and the car will not start even with spout removed, next I tested the tfi by bridge the 2 wires at the coil with a test light and cranking, the test light does not flash, which means the tfi is faulty? Car was working just fine, I put a msd coil and advanced the timing and it started this mess, but it ran better, ground from engine to battery is good, battery to car, head to fire wall, I’m I missing any? I’ve put the stock coil back on and still does it hahaha I’m about to pull my hair out someone please help
 
  • Sponsors(?)


Black_Mare

New Member
Dec 22, 2018
10
0
1
29
South florida
Also when the car dies if I unplug the tfi and plug it back in the car will start, when I put the new tfi the issue got better for a day then got worse and worse and worse, car is damn near undrivable how much it shuts off abruptly
 

Dan02gt

10 Year Member
Mar 2, 2003
649
282
113
Greenville, NC
Sounds like you have covered alot. How do your grounds look? Especially the one from the battery to the computer (the one that's grounded to the fender too)

I noticed that while working near the computer on mine it would die it I touched the harness near the computer connector. What I found was that the dedicated power and ground barrel connectors were loose on the computer pins. I depenned the computer connector and tightened the barrel connectors.

If you haven't already check and tighten the connections in the 10 pin salt and pepper connectors too.
 

DSB88GT

Active Member
Nov 6, 2016
175
40
38
48
First of all, you need to pull your codes. That will narrow it down for you. The TFI's are hit and miss, even the Motorcraft ones when new. It's very possible your new TFI is bad.
 

Black_Mare

New Member
Dec 22, 2018
10
0
1
29
South florida
Hey guys thanks for reply, there are no codes, it’s getting worse and worse car won’t idle for more then a minute or 2 shuts off no spark, turn key off and back on fires right up idles for 2 minutes dies no spark key off on fires right up on and on and on
 

Black_Mare

New Member
Dec 22, 2018
10
0
1
29
South florida
Well when the car dies if I jump the plug at the coil with a test light and crank the test light does not flash, which means the tfi is bad, I just bought this tfi brand new from ford dealer, I’m just making sure it’s not something else until I get a new one in, and make sure there’s nothing killing the tfi’s On the car, code 18 from what I’ve read allot of people say there’s a short somewhere, I have ran through all the wires I have all my grounds and spare grounds, I have tested everything I possibly can with all the different check lists available for fox body’s diagnostics, I keep concluding my tfi started going out then the new one was faulty out the box, a new new one is on the way but won’t be here until the day after Xmas, so I guess just enjoy the holidays and try to stay away from the garage as much as possible
 

jrichker

StangNet's favorite TOOL
SN Certified Technician
Mar 10, 2000
27,317
2,649
234
74
Dublin GA
lowendmac.com
Actually it’s throwing code 18, spout circuit open?

Code 18 - SPOUT out or wiring fault - look for short to ground in SPOUT wiring going
back to the computer. Possible bad TFI or defective 22 K resistor in the IDM wiring

Use a timing light to check the timing: remove the SPOUT and observe that the timing retards at least 4 degrees. Put the SPOUT back in place and observe that the spark advances at least 4 degrees.
This code can disable spark advance and reduce power and fuel economy.

Remove the passenger side kick panel and disconnect the computer connector.
There is a 10 MM bolt that holds it in place.
Disconnect the TFI module connector from the TFI and the measure the resistance between the yellow/lt green wire and ground.
You should see greater than 100 K (100000) ohms.
Check the resistance from Pin 4 on the computer connector (dark green/yellow) and the dark green/yellow wire on the TFI connector. You should see 20-24 K Ohms (20,000-24,0000 ohms).


Resistor location: A big thanks to liljoe07 for this information:

Check over by the brake booster. Its not in the harness on the TFI, its on the main part of the harness over by the plugs that connect to the dash harness. About 6" or so from that, going back toward the EEC.

If I remember right, the resistor is covered in a shrink tubing that is sealed to the wires. So, you wont be able see any markings. The shrink tubing is labeled though. It's a 22kohm 1/2 watt resistor.

Here is the location.



Next measure the resistance between the yellow/lt green wire on the TFI module connector and Pin 36 on the computer connector. With the SPOUT plug in place, you should see less than 2 ohms.

The following is a view from the computer side of the computer connector.
eec-iv-computer-connector-for-5-0-mustang-gif.gif


This diagram is the wire side of the computer connector.
a9x-series-computer-connector-wire-side-view-gif.gif


Diagram courtesy of Tmoss & Stang&2birds

88-91_5.0_EEC_Wiring_Diagram.gif
 

Black_Mare

New Member
Dec 22, 2018
10
0
1
29
South florida
So I find the 2 wires from ac melted touching each other, I take apart, start the car, idles for a while, longer then usual, thought I figured it out, dies, check code I get code 15, no more code 18, pull pin turn off car then restart, idles for a bit, dies, check code code 18 no code 15, what does this mean