'91 Mustang - Lower Radiator Hose Burst Driving Up Steep Hills

M36nace

New Member
Oct 18, 2016
2
0
1
33
Driving up one windy continous HILL... my Fox body SLUGGED up to the peak of the hill. Pedal to the floor, moving to the top speed of 5 MPH...the LOWER RADIATOR HOSE BURST!!! Rusty brown water and coolant SPRAYED the entire engine bay.
Now that I replaced the hose, slight coolant flush, NEW Coolant added,.. How do I.. or WHAT do I use to wipe down, CLEAN, power WASH maybe the entire engine bay and top cloth underneath the Hood with out damaging my engine further?!?
Engine Degreaser, Brake Cleaner, and....what can I use?
Thank you NEW Member
M36nace
 

Attachments

  • Sponsors(?)


Moosee1955

Active Member
Sep 30, 2016
267
55
38
64
I've got two questions, 1, why was your car only going 5mph uphill. 2, why are running Round with rusty water in system, and a hose ready to blow. Wow! I think cleaning your car should come second to what happened to your engine/ cooling system. I would think if all you want to get rid if gunk, is spray down dirty area with simple green or equivalent, use a brush, cover up dist cap with a plastic bag and rubber bands. Also cover alternator, spray it down at car wash or your driveway. And keep fingers crossed water doesn't sneak into anywhere important.


Sent from my iPhone using Tapatalk
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
4,624
3,902
183
41
Purple power. Be very careful with the hood insulation.

On the engine bay I've used a plastic bristled hand held broom, a spray bottle for purple power, a garden hose, and a finishing touch of enginebrite with good results. Might be a better idea to buy a new hood insulator. Those thing tear up pretty easy.
 

Black1987

5 Year Member
Jan 9, 2011
1,004
581
164
NC
Simple green also works, just take your time .

Now the hose issue, is that wear at the base of the start of the tear? I would try to contact the manufacture, because that type of failure is worst case scenario. Was your radiator clogged and or was the spring anywhere to be found?

I seen the without the spring a less serve hose burst, but only once and it was dry rotted.
 

M36nace

New Member
Oct 18, 2016
2
0
1
33
I've got two questions, 1, why was your car only going 5mph uphill. 2, why are running Round with rusty water in system, and a hose ready to blow. Wow! I think cleaning your car should come second to what happened to your engine/ cooling system. I would think if all you want to get rid if gunk, is spray down dirty area with simple green or equivalent, use a brush, cover up dist cap with a plastic bag and rubber bands. Also cover alternator, spray it down at car wash or your driveway. And keep fingers crossed water doesn't sneak into anywhere important.
Also as far as the cooling system..I dont think its the head gaskets.. But since i have a lot of work to do.. Head gaskets should be replaced with the radiator upper radiator hose. Possibly the timing belt as well when i replace the cam or crank position sensor. A new water pump belt would hurt either. Since ive driven with out one since i bought the car.


Sent from my iPhone using Tapatalk
1 she was going 5 mph because the transmission is going out and the cam or crank position center needs to be replaced.
2 ive flushed the system 3 times now in the last 4 months. It must be the radiator that need to be replaced as far as the rust is considered... Far as i know. 90$ The lower hose I had no idea was ready to burst. I assume the cut was on the engine side where i couldn't see when I changed the THERMOSTAT not too long ago.