Electrical 95 cobra random dyno numbers

Moeofit32

New Member
Apr 9, 2020
5
0
1
34
California
My car is a 1995 cobra with 351 Windsor stroked hci Novi 2000 on e85 and meth with a t4mo computer and a sct chip. My issue is that I've had my car on the Dyno recently and discovered that although my car runs well with no issues my power is all over the place. Did about 10 passes and my car made anywhere from 500-730 hp. I was able to confirm that my afr was a bit rich but nothing crazy, fuel pressure is consistent around 40lbs if I remember correctly,boost is15-16lbs the only things I can't monitor is ignition/timing. I recently replaced the act sensor,coolant air temp sensor, cleaned my maf full blown tune up any help would be greatly appreciated.

Here is 3 of my pulls the short one my friend got scared cause the car acted different but it sounded how my car normally sounds when it's performing properly,notice I gain 100 hp out of nowhere and the short pull both seem to possibly end the same. We did about 10 pulls and the power was all over the place. I do have a check engine light that seems to be smog equipment and 02 sensors so im working on that currently.
 

Attachments

  • IMG_20200411_224153_530.jpg
    IMG_20200411_224153_530.jpg
    125.8 KB · Views: 51
  • Sponsors(?)


StangNet created a new car social app called knowmoto! Add your Mustang or post a photo in the knowmoto app and enter for a chance at a $100 gift card from LMR. Click the LMR Logo for more about the knowmoto Mega Thread!

jrichker

StangNet's favorite TOOL
SN Certified Technician
Mar 10, 2000
27,426
2,758
234
75
Dublin GA
lowendmac.com
My guess at this time is that the spark advance is wandering all over the place. A timing light used to monitor the spark advance would confirm or deny this theory.

If you have an Air/Fuel Ratio gauge, monitor the readings as you do the dyno run. A widely varying A/F ratio would also give you the same results.
 

Moeofit32

New Member
Apr 9, 2020
5
0
1
34
California
I did notice moisture in my cap and I tryed to put in a AutoZone one with the gear swap from my msd distributor but it didn't sit flush. I ordered a new one from summit it comes with the steel gear do I need to swap it if my car is running the F cam?
 

96pushrod

I think they're a little easier to get off
May 15, 2018
972
588
103
29
Savannah
Timing would have to swing massively to see 200hp differences. Can you measure egt on the Dyno? How is it being tuned without timing being monitored?

All roller cams will need a steel gear.
 

Moeofit32

New Member
Apr 9, 2020
5
0
1
34
California
well i got the car on the dyno yesterday and its still down on power and drove to and from the dyno (45min drive one way) issue free. I pulled my plugs last night and cylinder 3 looks damn near brand new so im thinking spark or fuel, but why would it still run good?
 

Moeofit32

New Member
Apr 9, 2020
5
0
1
34
California
I got home today and did some investigating and sure enough my brand new Taylor wire is not giving me good spark. I pulled the wire completely off and my car still started and idled fine I noticed the spark was strong at the cap so I then hooked up the wire and it was only sparking every like 1.5 to 2 seconds so I put a old wire on and Wala we got spark that looks good. Took it for a test drive and it felt good, got home and pulled the plug and now the sparkplug looks like it was
being used