95 GT Cold Start Surging, Occasional Stalling, Intermittent CEL

Tolpeko

New Member
Feb 6, 2019
2
0
1
PA
Hi all! Sorry to be asking for help in my first post, but I figured it's better than the endless searching I've been doing.

The symptoms in my 95 GT are:
  • Surges for the first minute in cold weather, usually goes away once I give it some gas and start driving.
  • Stalling in freezing temps once the car warms up. It wouldn't stay running recently in 20° weather unless I gave it some gas, and putting it in gear was almost a guaranteed stall. It was actually running fine until it reached operating temp.
  • Intermittent CEL, more frequent the colder the weather. I checked codes but I'm not getting any.
The car runs perfectly other than these issues, but it's not really reliable in freezing weather right now. I went through the checklist of surging issues and thought maybe it's the IAT sensor. The resistance looks good (I only measured one value). The voltage coming out of the connector is 4.5v and I read it's supposed to be 5v. Is that within normal range or is that an issue / what should I test next?

If it helps, here is a service record of what's been done since I got the car. It has no mods other than aftermarket exhaust and deleted EGR.

Thanks for any help/suggestions!!
 
  • Sponsors(?)


jozsefsz

5 Year Member
Aug 11, 2013
1,148
272
114
49
Cleveland OH Area
The checklist kind of assumes your car is in a reasonable state of tune. Fresh gas, decent plugs / wires / coils / cap & rotor / fuel & air filters, clean oil, clean injectors, no vacuum leaks (the vapor purge line is always suspect). If your O2 sensors haven't been changed in a long time, a lot of miles, or forever, they're overdue. Cleaning your MAF wouldn't be a bad idea either. I'd start there.

As you mentioned you followed the checklist, your car runs ok with the IAC altogether disconnected? You adjusted the throttle stops and idle air bleed to keep it running (at a low RPM) with the IAC unplugged? You then cleaned the IAC, disconnected the battery for 15 minutes to reset the adaptive learning, reconnected?

If you follow all of those steps, primarily related to the IAC, and your car is in a good state of tune, with all vacuum lines checked, that should eliminate the stalling.
 
  • Like
Reactions: Tolpeko

Tolpeko

New Member
Feb 6, 2019
2
0
1
PA
When you say you get no codes, you should get the 11 for all clear, everyhing checked good.
Yep, my mistake, I meant all clear, at least for KOEO. I do get 311 and 314 (AIR system inoperative) during KOER, but I thought that was from the EGR delete.
The checklist kind of assumes your car is in a reasonable state of tune. Fresh gas, decent plugs / wires / coils / cap & rotor / fuel & air filters, clean oil, clean injectors, no vacuum leaks (the vapor purge line is always suspect). If your O2 sensors haven't been changed in a long time, a lot of miles, or forever, they're overdue. Cleaning your MAF wouldn't be a bad idea either. I'd start there.

As you mentioned you followed the checklist, your car runs ok with the IAC altogether disconnected? You adjusted the throttle stops and idle air bleed to keep it running (at a low RPM) with the IAC unplugged? You then cleaned the IAC, disconnected the battery for 15 minutes to reset the adaptive learning, reconnected?

If you follow all of those steps, primarily related to the IAC, and your car is in a good state of tune, with all vacuum lines checked, that should eliminate the stalling.
Yep it is in pretty good tune and has basically a new/clean everything. It was running horribly before that, but there's still this one little issue remaining. I haven't checked it with the IAC disconnected so I will look into that. I can't rule out a vacuum leak either!

Thanks for the replies!
 
Thread starter Similar threads Forum Replies Date
8 Cold start surging (data log included) Digital Self-tuning Forum 7
Onesick99GT 99 Mustang GT High Rev On Cold Start SN95 4.6L Mustang Tech 25
John Dirks Jr Minor Cold Start Idle Surge Fox 5.0 Mustang Tech 2
tca7291 Engine Arrghhh! Cold Start, Surging/stalling Problem Fox 5.0 Mustang Tech 33
notch351 still problems surging idle on cold start 1994 - 1995 Specific Tech 19
mustang70 Cold Start Digital Self-tuning Forum 9
silverlx50 Engine UPDATED WITH FIX IN POST #49 Help with sputter issue with cold starts Fox 5.0 Mustang Tech 49
R 98 GT having cold start issues 1996 - 2004 SN95 Mustang -General/Talk- 6
A wont start back up after drive will start on cold start up 2010 - 2014 Specific Tech 1
B Cold Start Rough Idle Fox 5.0 Mustang Tech 9
H 66 mustang cold start blows a little carbon. 1965 - 1973 Classic Mustangs -General/Talk- 4
C cold start 1965 - 1973 Classic Mustangs -General/Talk- 0
ChillPhatCat Cold Start Issue... ACT Sensor? '89 LX 2.3L 2.3L (N/A & Turbo) Tech 27
9 MS2 Cold Start Issues Digital Self-tuning Forum 6
9 Microsquirt with strange cold start problem Digital Self-tuning Forum 5
allutz Cold start extended crank issue SN95 4.6L Mustang Tech 12
0 2003 Ford Mustang V6 3.8L gets around 12mpg and seems to shake a bit when started cold and has a bad rough idle when warm SN95 V6 Mustang Tech 5
A Engine Crank, no start on cold start. Fox 5.0 Mustang Tech 19
R 89 2.3 Mustang Turning over, not starting in cold weather 2.3L (N/A & Turbo) Tech 1
K Engine '87 GT cold start problem after working on a/c??? Fox 5.0 Mustang Tech 11
D Engine 1993 2.3L LX Cold Starting Issue Below 20 Degrees Fahrenheit 2.3L (N/A & Turbo) Tech 11
C Bad cold starts and leaking PCV hose SN95 4.6L Mustang Tech 3
S 1968 Mustang Cold Starting Issue Classic Mustang Specific Tech 3
02 281 GT 1995 Cobra - high cold start idle, flashing CEL, miss/hesitation/low power when driving 1994 - 1995 Specific Tech 5
H Engine 2.3l 1988 mustang lx cold start problems and bad idle. 2.3L (N/A & Turbo) Tech 1
C White Smoke Coming Out of Pipes on Cold Start 2005 - 2014 S-197 Mustang -General/Talk- 2
J Engine 92 mustang rough cold start Fox 5.0 Mustang Tech 3
98stang_v6gang Blue Smoke On Cold Start SN95 V6 Mustang Tech 9
sweendog1969 Engine 05 Gt 5spd Cold Start Low Idle And Die If Try To Drive 2005 - 2009 Specific Tech 4
Nightstang00 Cold Starts Fox 5.0 Mustang Tech 5
1 92 Gt Rough Idle On Cold Starts (long) Fox 5.0 Mustang Tech 2
EleanorGTCSSavior '07 Gt/cs Knocking From Dash After Cold Start 2005 - 2009 Specific Tech 9
5 Cold Start And Stalling Sometimes When Coming To A Stop Fox 5.0 Mustang Tech 11
Keith5.0GT Cold Start And Koer Help Fox 5.0 Mustang Tech 33
9 Stalling On Cold Start Fox 5.0 Mustang Tech 6
TheJarlofNewEdge 99-04 Gt, Calling All Mechanical Bug Wizards SN95 4.6L Mustang Tech 10
M Fox 1991 Mustang Gt No Start When Temp Is Below 50f. Need Help 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 9
Joseph Ferrigno 2000 Gt Hesistation On Cold Start-up SN95 4.6L Mustang Tech 22
M Low A/f Ratio Cold Start? SN95 4.6L Mustang Tech 0
NRB Auto 01 Gt Cold Start Idle Fluctuation? 1996 - 2004 SN95 Mustang -General/Talk- 1
DriveThru Low Vacuum Reading - Car Dying On Cold Start Fox 5.0 Mustang Tech 1
J Help Cold Start Stalling SN95 4.6L Mustang Tech 3
VintageAion Engine High Rpm Cold Start 2005 - 2009 Specific Tech 3
Hector Castillo Engine Shaking On A Cold Start SN95 4.6L Mustang Tech 2
4 Squeaking After Cold Start 2005 - 2009 Specific Tech 0
camaroguy72 Help Needed- 95 Mustang Gt Intermittent Cold Start Issue, Rpm Drop Randomly On Highway 1994 - 1995 Specific Tech 24
R Cold Start Problemz Fox 5.0 Mustang Tech 6
timjimmy Engine Rough Cold Start 2005 - 2009 Specific Tech 7
Micheal Nadeau Cold Start Issue 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 9
O Engine Hard Start When Cold And Hot Fox 5.0 Mustang Tech 3
Similar threads