brake rotors really hot but doesnt seem like they should be

mostsmooth

Active Member
Nov 12, 2002
264
25
29
Visit site
hi all,
95 gt
i put on new rotors and pads.
stock size

I did the break-in procedure including cool-down period.
after some very easy driving with minimal braking, when I got home for fun I checked the rotors. fronts were very hot. not sure if this is normal.

when I put the pads on, they were a very tight fit. if I was doing my honda brakes, I would have ground 0.5 mm or so off the tabs, and then they slide nice and easy.
I didn't grind these because I have some new calipers coming and I didn't know if I ground these a bit would they be too loose for the new calipers.

so, the rotors shouldn't get so hot for no reason, right? I'm guessing that the pads may just be slightly rubbing on the rotor the whole time and heating the pads up. I am further guessing that if I ground the tabs a tiny bit, it would help, unless its a caliper thing.

more info: a week or two ago i had a problem with some serious brake fade and i found the back calipers were both stuck (the pins or whatever they are called) and the back rotors were super hot (and the calipers if i recall correctly). i unstuck them and they seem to be fine. the back rotors do not heat up now. when i did the brakes, i checked the front calipers and they seemed to be moving fine.

am I way off base on this? front rotors shouldn't be getting so hot under casual driving with only light occasional braking, right?

thanks
 
  • Sponsors(?)


StangNet created a new car social app called knowmoto! Add your Mustang or post a photo in the knowmoto app and enter for a chance at a $100 gift card from LMR. Click the LMR Logo for more about the knowmoto Mega Thread!

dcm0123

Member
Mar 11, 2017
45
10
18
20
There will be some heat but hard to define what amount is to much.
If you are concerned there is brake drag, jack the car up, press down hard on the brake, let up then try to spin the tire. If you feel brake drag then take it apart to find out what caused it.
 

mostsmooth

Active Member
Nov 12, 2002
264
25
29
Visit site
There will be some heat but hard to define what amount is to much.
If you are concerned there is brake drag, jack the car up, press down hard on the brake, let up then try to spin the tire. If you feel brake drag then take it apart to find out what caused it.
thanks
smart, simple. i dont know why i didnt think of that
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
36,174
12,089
224
Massachusetts
Check the slide pins on the front calipers and make sure they are freely moving and well lubricated. Often, i've seen these seize up so when a new set of pads is installed, they drag excessively and heat up.
 

mostsmooth

Active Member
Nov 12, 2002
264
25
29
Visit site
Check the slide pins on the front calipers and make sure they are freely moving and well lubricated. Often, i've seen these seize up so when a new set of pads is installed, they drag excessively and heat up.
I checked then when I put the pads on. They seemed 'ok', but my judgement may be bad. Normally I wound have taken them apart and lubed them, which I did for the rears, but the fronts have some weird (to me) set up. There's only 1 bolt. I wasnt sure what would happen if i took the bolt out and i didn't want to break it by taking it apart wrong, so I left it as is.
I will start with what dcm suggested and go from there
 

90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,993
5,141
203
43
A cheap temlerature gun can really help diag some stuff. My truck had a warped rotor so I checked all 4 with my temp gun. Both rears were 174°, right front was around 180°, left front was 200° plus. It showed almost 300 ° near the base of the pad contact. Pulled that wheel off and found the lower caliper pin was frozen.

I do a bunch of brakes and almost always file the edge of the pads down a little. I like to get rid if the hard corners so they slide easier. The cheaper pads are the worse. I don't think you'll have a problem with installing them in new calipers if you only take off a tiny bit. When you install them add a little bit of thus to the areas where the back of the pad contacts the caliper and the piston. It will glue them down and keep them from shifting and causing noise. Be neat and only coat the part that's covered by the caliper. This stuff isn't the purdiest shade of orange. It's sold at most local parts stores.

Screenshot_20210504-005816_Amazon Shopping.jpg
 

Mustang5L5

Put lubricant all over the balls
Mod Dude
Feb 18, 2001
36,174
12,089
224
Massachusetts
I checked then when I put the pads on. They seemed 'ok', but my judgement may be bad. Normally I wound have taken them apart and lubed them, which I did for the rears, but the fronts have some weird (to me) set up. There's only 1 bolt. I wasnt sure what would happen if i took the bolt out and i didn't want to break it by taking it apart wrong, so I left it as is.
I will start with what dcm suggested and go from there

These are OEM 1995 Brakes right? They haven't been swapped to anything?
 

mostsmooth

Active Member
Nov 12, 2002
264
25
29
Visit site
These are OEM 1995 Brakes right? They haven't been swapped to anything?
Stock.
Pic attached. Yellow arrow is where there is a bolt with a torx head and I can see it without removing anything. Red arrowside appears to be just a cover. I didn't want to try and take that cover off and break it.
 

Attachments

  • 20210504_114028.jpg
    20210504_114028.jpg
    332 KB · Views: 22
  • Like
Reactions: 1 user

dcm0123

Member
Mar 11, 2017
45
10
18
20
Looking at the rust on the caliper it look like the original. Did you feel any resistance when you pushed the piston back in? If so, it could be starting to seize up.
 

revhead347

Apparently my ex-husband made that mistake.
15 Year Member
Jun 14, 2004
8,838
1,482
214
41
Acworth, GA
The most common failure I see is people not cleaning out the pins and re lubricating them. Sounds like you figured it out.

Just FYI, those brake bads are designed to be installed with the caliper bracket still on the car. It looks like you took the whole assembly off. You hold the rotor tight to the hub with a lug nut. Install the caliper bracket onto the car, put the pads in the caliper bracket, and then put the caliper over the pads. Makes it way easier.

Kurt
 

mostsmooth

Active Member
Nov 12, 2002
264
25
29
Visit site
The most common failure I see is people not cleaning out the pins and re lubricating them. Sounds like you figured it out.

Just FYI, those brake bads are designed to be installed with the caliper bracket still on the car. It looks like you took the whole assembly off. You hold the rotor tight to the hub with a lug nut. Install the caliper bracket onto the car, put the pads in the caliper bracket, and then put the caliper over the pads. Makes it way easier.

Kurt
i replaced rotors, so had to take the calipers off.
and yeah, i dont install the pads with the assembly all in one piece, i have it apart. i took that pic before i started taking it apart cause i wanted to make sure i put the new clip back in correctly.
 

90sickfox

Wasn't a pretty sight...and I've got big hands
SN Certified Technician
Mar 2, 2015
5,993
5,141
203
43
If it took two c clamps to get the pistons to go back then you need s new caliper. It shouldn't be that hard.
 
  • Like
Reactions: 1 user