Fuel Brand new sending unit at E with full tank.

Rdub6

So while I wait to figure out my rear end issues
Dec 29, 2017
2,537
1,868
133
Long Island, NY
I think I am just going to order another one from LMR. I don’t want this car laid up while I wait for parts.
If it’s the connections, LMR will take it back I’m sure..... if it’s the wrong unit..... new one in, and I’m back on the road!! Then I deal with Rock Auto for a return on that one (have to see how long ago I bought that)
 
  • Sponsors(?)


Willybill32

But at least it's tight!
Jul 16, 2019
279
109
53
Lexington, KY
Is there any chance you’ve had the gauge cluster out during this ordeal? On my ‘86, I had the gauge cluster out several times. One time after reinstalling it, the gas gauge didn’t work. When I removed the cluster, I found the copper land had separated from the flexible circuit board, messing up the gas gauge connection to the circuit.
 

Rdub6

So while I wait to figure out my rear end issues
Dec 29, 2017
2,537
1,868
133
Long Island, NY
Is there any chance you’ve had the gauge cluster out during this ordeal? On my ‘86, I had the gauge cluster out several times. One time after reinstalling it, the gas gauge didn’t work. When I removed the cluster, I found the copper land had separated from the flexible circuit board, messing up the gas gauge connection to the circuit.

I did, but when I put fuel in from the cans it did move to between E and 1/4. Then when I filled the tank, it went to dead E. I had not touched the gauges in between those two fuel additions.
I guess for a few minutes and a few screws, it wouldn’t hurt to look though.
 

Rdub6

So while I wait to figure out my rear end issues
Dec 29, 2017
2,537
1,868
133
Long Island, NY
Drove the car a bit this weekend. It now has about 30 miles on the new tank of gas, and it seems the needle is starting to work it’s way backward.
I just got the new sending unit in the mail from LMR.
I ohmed it out and it is perfect to the ‘86 specs.... about 73 empty and 8-10 full, with even transition from one to the other.
I should have checked the one I received from Rock Auto before I installed. Live and learn..... anyway, I am curious to see what it’s readings are once I get it out.
 

Rdub6

So while I wait to figure out my rear end issues
Dec 29, 2017
2,537
1,868
133
Long Island, NY
I put some stuff in my progress thread, but just to button up this one.... ordered a new sender from LMR, and it OHM’d correctly.
The old “new” one from Rock Auto OHM’d at the ‘87 up levels. Part number on box matched what they listed for ‘86, but no identification on part itself. Whether they are selling wrong one, or I got one that somebody else stuck in the box and returned, who knows? Fuel gauge now works like it should, and I emailed Rock Auto today to explain my story. Bought it in March, but I’m ok with store credit since I’m long past their return policy. Hopefully they do something to make this right!
 

Rdub6

So while I wait to figure out my rear end issues
Dec 29, 2017
2,537
1,868
133
Long Island, NY
Got an email today from @RockAuto that they will take my return for store credit, even though it was well past the 30 days! Great customer service!!
 
  • Like
Reactions: 1 user