Progress Thread Budget 89 GT

  • Sponsors(?)


Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
ok.... ill try a pump first. at full boost t should go to 45 i would think since there wouldnt be any vac.

i was reading through my manual last night trying to remember if i could only use low or high impedance injectors on the microsquirt
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
alright sweet. so if need be i can use the ford racing 60s or something if it ends up being the more expensive problem. id just have to buy a harness adapter
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
ive seen some people run a 450 or twin 450s and make their own hat for the stock fuel tank before. i shouldnt need all that tho.

maybe one day ill get a 351 and make some big power.

i think on3 sells and aftermarket hat as well
 

stanglx2002

Mod Dude
Jul 7, 2005
1,192
739
154
ive seen some people run a 450 or twin 450s and make their own hat for the stock fuel tank before. i shouldnt need all that tho.

maybe one day ill get a 351 and make some big power.

i think on3 sells and aftermarket hat as well
They do but you have to use the 03-04 cobra tank to use it. They have a different hat for triple fuel pumps.
 

stanglx2002

Mod Dude
Jul 7, 2005
1,192
739
154
I hope this addresses the fuel psi issue that you were having. Then you should be getting some more bandwidth out of those injectors.
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
ME TOO!! time will tell i didnt get it done till 10:30 last night. i had a bunch of stuff to do after work.

ill try and drive it maybe tonight and see what it does.
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
getting everything ironed out again...

now im looking into c4 swaps.... i dont really like auto cars but it seems like it would be and upgrade if im looking to go faster in the 1/4. right now im losing a lot of steam in between gears....

anyone on here switched from manual to auto that can chime in?
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
@a91what can you look at these and tell me if you see anything weird. car runs really good. at about 4800 and up it starts to break up almost like a fuel problem. only other thing i could think of is like a valve train problem? thing is a monster now.....

wondering if the injectors need to be swapped. i already swapped the pump like we said. looks like it asking for some fuel mid way in the rpm range when i hardly ever drive under boost. didnt want to touch anything till you looked at it.
 

Attachments

CarMichael Angelo

Nobody appreciates me..I'm gonna cut my ear off
SN Certified Technician
Nov 29, 1999
11,554
12,482
234
61
Birmingham, al
m.imdb.com
getting everything ironed out again...

now im looking into c4 swaps.... i dont really like auto cars but it seems like it would be and upgrade if im looking to go faster in the 1/4. right now im losing a lot of steam in between gears....

anyone on here switched from manual to auto that can chime in?
What are you looking for? It's like you've said already. Itll be faster when you dump the manual trans.
 

Anti_Hero0932

5 Year Member
Jan 29, 2012
379
176
63
28
LaGrange, MO
ive already figured out the C4 part of it. ill probably wait till this winter to do that. might have converter questions at some point. right now im just trying to figure out why this car is still breaking up at the top end of the RPM range. wondering if its injector or something or if im floating valves or what. im wondering if i need to move to 60# injectors now..