CLUTCH CABLE

hhenshaw59

Member
Nov 17, 2021
4
1
13
62
NORMAN, OK
I just upgraded my 76 Cobra to an 88 5.0 with a T5 trans. I am having problems with the old clutch cable from the T4 trans that was in it with the original 5.0. Can anyone help me out with what clutch cable I need to use for this application.
 
  • Sponsors(?)


LILCBRA

I wish I didn't have all of these balls in the air
15 Year Member
Dec 6, 2005
3,349
2,590
174
49
Marietta, Ga
I'd suspect the stock cable. What kind of problems are you having?
 

LILCBRA

I wish I didn't have all of these balls in the air
15 Year Member
Dec 6, 2005
3,349
2,590
174
49
Marietta, Ga
With the RAD bellhousing, there is a boss with a hole where the cable is stuck through. The cable is threaded on that end and attached using jam nuts. I'm pretty sure that that adjustment is for the cable length to get you in the ball park. Then, there's a piece that's attached to the firewall that I think looks like a rook chess piece. The cable has a "nut" on that end as well with 2 tangs that lock into the grooves in the castle part of the rook piece. That's where the pedal adjustment is made. If you're unable to secure the cable at the bell housing or are missing the rook piece I'd suspect you'd run into problems.
 
  • Like
Reactions: 2 users

IICrew

Advanced Member
Mar 29, 2020
216
292
73
USA
Lilcbra hit the nail on the head above. The cable is held in place by the hole in the bell and firewall mount.

I installed a t5 and used the stock cable. I am using the rad4 bell though.

One problem I had was the spring on the cable is too long. I had to cut it down to about 1/3 the original length. Another problem I had was the headers melted the cable during initial engine break-in.

Can you get us a pic of cable at the firewall and the clutch fork/lower anchor point?
 
  • Useful
  • Like
Reactions: 1 users

IICrew

Advanced Member
Mar 29, 2020
216
292
73
USA
I looked up pictures of the fox t5 bell and its the same as the rad 4. Just clocked closer to 9 vs our 7.

What exactly is happening? Is the pedal firm but the clutch engaged? Is it slipping?
 

2Blue2

will be trying this sex one when I can find it
Mod Dude
Mar 5, 2019
3,148
2,086
143
54
Oahu
Can you get us a pic of cable at the firewall and the clutch fork/lower anchor point?

Heres some of it

IMG_0722.JPG
IMG_0724.JPG
IMG_0723.JPG
IMG_0727.JPG


IMG_0725.JPG
 
  • Like
Reactions: 1 user

Enzio

Dang it. I was hoping mine would get 3 more inches
May 14, 2019
862
678
103
65
Minnesota
We are going to need some more info. I personally have changed the clutch and cable several times. I was using the stock bell housing.

A picture of the fox bell would work from the rear. I don't know if there is room to get the cable in the hole or not but assume so as you said above that you're having problems getting adjustment out of the cable. So I'm assuming you've had it in there.

Does the cable slide back and forth easily? If so I'd still spray some graphite lube in there just because.

install the cable through the firewall and hook it up to the pedal. I'd make sure there is a plastic bushing where the cable goes around the pivot. (I couldn't find a replacement and used an "anti-short bushing for MC cable" got it from my local home depot. Just ask the guys in the electrical department. It'll be little and red and come in different sizes. It worked for about 10 years. Oh, and beware the exhaust manifold/headers. The cables burn/melt and then you'll need to do this over.

Take all of the adjustment out of the cable. (turn the blue adjusting knob toward the rubber casing on the cable.)

Now thread the clutch end of the cable down to the bell and through the hole of the bell. Put a nut on the cable on the rear side to hold it in place.

You should be able to put the cable "ball end" through the fork. Push the cable slack back through the cable sheath towards the firewall. (it is really helpful to have another person up at the firewall and start taking the slack out using the Blue adjusting nut while you make sure the Ball end of the cable stays where it should be in the fork.

Keep going. I've always liked the cable to be so tight that I pulled on it very hard and had someone using a properly sized wrench to crank it down. I'm not the only one because as you can see the the firewall tube is busted up where the teeth from the blue nut are supposed to sit. They all are.

Your done. Go for a ride.

A problem. I used the spec clutch replacement. In that case there is a significant difference in the depth of the pressure plate and I had to "shim" up the adjustment at the firewall to give me more adjustment. It worked. I think I used some Heavy duty washers. If you're using a stock fox clutch I don't know if there will be a problem.
 
  • Like
Reactions: 1 users

Enzio

Dang it. I was hoping mine would get 3 more inches
May 14, 2019
862
678
103
65
Minnesota
Oh and get rid of the spring. It does nothing for you except bind up.
 
  • Like
Reactions: 1 user