Cooling troubles

Stangstr5.0

New Member
Jun 10, 2019
5
0
1
46
Hayward ca
I have a 94 5.0 that gets really hot only when driving and hood is closed . When idles and hood is open it stays on O.R on the gauge . I had to prop thmthe hood the other day with a tshirt in the corner of my hood when I closed it to have a gap to allow air in to keep it cool. The fans go off when they are supposed to and I used a combustion gas tester and it showed I had no gase in my radiator it stayed blue .... I'm confused I changed my thermostat also to a 170
My needle on my gauge also jumps around just wondering if my sending unit could be bad and geting to much heat when my hood is closed to make it jump around or my radiator or waterpump..????? Coolant seems to be moving inside if radiator .... I am nervous I dont wanna eff my car up what to do I am thinking of draining my coolant doing a flush I also noticed the bottom hose that goes to he pump is hard ass hell and seems crunchy when you squeez it like something is inside
 
  • Sponsors(?)


General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
13,561
4,273
193
polk county florida
Let get back to basics here.
put the recommended temp thermostat back in, I think it would be around 190-195*, make sure you burp the system, that is after you replace all the hoses that are suspect. Install a manual temp gauge to check actual temp. Make sure there is no junk between the radiator and condenser in front of it and the air dam under the car is in place.
 

Stangstr5.0

New Member
Jun 10, 2019
5
0
1
46
Hayward ca
Let get back to basics here.
put the recommended temp thermostat back in, I think it would be around 190-195*, make sure you burp the system, that is after you replace all the hoses that are suspect. Install a manual temp gauge to check actual temp. Make sure there is no junk between the radiator and condenser in front of it and the air dam under the car is in place.
Can the hoses make it run hot