Progress Thread Dsg Mach's Mustang

  • Sponsors (?)

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#62
Sent the car to the shop to have them check it out and figure out what its going to cost to fix. Prob wont hear anything for a few days.
 

Neuron

Mustang Master
Nov 6, 2016
623
125
83
68
#63
Hope it works out OK.
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#64
Got the car fixed. They checked it out and the valves were not damaged. They replaced the spring now it drives. However I'm getting a ticking noise from the head. I didn't realize the lash adjusters need shims under them. I ordered shims and hope to install them this weekend. If this doesn't solve the problem I don't know what I'll do. Also my check engine light came on for the p1506 code. I guess I need a new IAC valve.
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#65
Found out why the car was making noise. Ordered a new set of rocker arms from American Muscle.
 

Attachments

Mattstang04

10 Year Member
Sep 15, 2006
1,124
137
104
St. Louis, MO
#66
Yep. That'll make some noise. You're really having to sort out this valvetrain. Hopefully that fixes all of it.
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#68
So I feel defeated right now... The car idles at 2,000 rpms and has CEL code P1506. I looked it up and they recommended replacing the IAC valve. I ordered a Motorcraft one from CJ Pony parts with the new gasket. I put it on and got the car all buttoned up and it idles at 2000 rpms. It dips and goes up but wont settle to 900rpms. Also I have an oil leak somewhere as there is a lot of smoke coming from the passenger side where I had to fix the rocker arms and valve springs. I thought the valve cover seal was not good but I looked and I see no oil on the headers. Im at a loss and I dont know what I am going to do.


On the bright side I dont have a damaged valve and the car does not make the noise it used to make with the broken rocker arm.


If anyone can help me I would appreciate it. I know these forums are pretty dead but I really need some help.


Thanks
 
Nov 4, 2013
224
23
39
27
Ca
#69
Just a tip, every time my IAC went bad I had to disconnect the battery and reset the pcm so it cleared all the last bad values of every sensor and relearn everything. Did you try that? Worth a shot and is easy
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#70
Just a tip, every time my IAC went bad I had to disconnect the battery and reset the pcm so it cleared all the last bad values of every sensor and relearn everything. Did you try that? Worth a shot and is easy

No I didn't even think to do that. I will do it when I get off work today. My main concern is the oil leak. Im pretty sure the valve cover seal isn't seated correctly. Thank you!
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#71
Car still idles high. I have not driven it. It now sits at 3,000rpms. When I disconnect the sensor to the MAF it idles just fine at 900rpms. I don't know what to do now?
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#72
Here is a video of the car idling with the MAF disconnected. I have a ticking noise that I am not sure what could be the issue. One of the rocker arms was loose and didnt have a shim under the lash adjuster. When I put the lash adjuster under it the rocker arm was taught like it should be and not loose. I should of checked the other but I thought that was it. I am going to check when I can and put shims under the ones that are loose.

View: https://www.youtube.com/watch?v=LWv_Mx9jWeY
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#73
Well the brand new rocker arm snapped on the new valve spring again... Its too strong.
 

Attachments

Last edited:
Nov 4, 2013
224
23
39
27
Ca
#74
I’m back, and wow! I’ve never seen so many broken rockers before!! Do they make upgraded rockers so you stop breaking them? They are easy to replace. As far as unplugging the maf to being idle down I dunno why it’s doing that I would love to hook my my scan tool and see what the maf sensor readings are at and other sensors.
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#75
I’m back, and wow! I’ve never seen so many broken rockers before!! Do they make upgraded rockers so you stop breaking them? They are easy to replace. As far as unplugging the maf to being idle down I dunno why it’s doing that I would love to hook my my scan tool and see what the maf sensor readings are at and other sensors.

I bought brand new Melling rocker arms and thought it would be fine as the others are Melling and have not snapped. I ordered this kit from American Muscle. I ordered it before but could not for the life of me figure out how to put them on. I returned them but my friend who is an engine nut said to buy em again and he would help me install them. I didnt find any videos of how to install them on YouTube. I guess I will make a video of how to do it if he can figure it out.

https://www.americanmuscle.com/frpp-4v-rocker-set-9612.html




The other part of me just wants to take it back to the shop and ask them to put a spring in that is not so tough but the car has aftermarket cams and I dont want a factory spring in there cause it will fail again...
 
Nov 4, 2013
224
23
39
27
Ca
#76
Huh... well I’ve done lifters a ton of times and you have to remove the rocker to do them. You have a 4.6 sohc engine right? All you have to do is remove the valve cover, turn the crank so that the cam lobe is facing up on the rocker, and pull it out. Unless there is something special about the heads you’re using? I might be missing some info on your set up
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#77
Huh... well I’ve done lifters a ton of times and you have to remove the rocker to do them. You have a 4.6 sohc engine right? All you have to do is remove the valve cover, turn the crank so that the cam lobe is facing up on the rocker, and pull it out. Unless there is something special about the heads you’re using? I might be missing some info on your set up
No its a 4v DOHC 4.6L engine for the Mach One. I know how to change the rockers though. The new rockers I bought are different in the style compared to the Telling rockers. I'm not to sure on how to install them but my buddy is going to help.
 

DSG_Mach

Active Member
Jul 23, 2016
121
16
38
27
#78
The car died this morning after making a noise and it just sputtered and stopped. I dont know what could of broken. Im guessing a valve dropped but I dont know. It is at the shop to be looked at.
 

Neuron

Mustang Master
Nov 6, 2016
623
125
83
68
#79
What a bummer, sorry to hear that, fingers crossed. Await the diagnosis.
 

Mattstang04

10 Year Member
Sep 15, 2006
1,124
137
104
St. Louis, MO
#80
This is turning into a war of attrition. Those rocker you bought are the 05 06 Ford GT Supercar rockers. That's what all the 4v guys seem to use when they cam up the engines. They should be stronger than the standard replacement or the Mellings. Hopefully, you don't have a stuck valve breaking those rockers.
 

Similar threads