Electric fan fail

87LXVERT

New Member
Jul 5, 2021
5
0
1
60
East Greenwich, Rhode Island
Very new to foxbody so I have a lot to learn. Despite working on cars for better part of 45 years. If you ever need help with a 1994-01 BMW E38, especially the V12, I'm your guy.... Have had my 87 LX 2.3L for about 9 months. Yes it's missing 8 cylinders from what i'm used to lol. When I got it in the fall, if I just let it sit idling doing whatever, eventually the electric fan would come on.
Then one time it didn't an overheated just sitting there. Wasn't watching the temp gauge. Didn't feel I needed to but boom! Happened at least one more time also. Driving is fine of course because there is plenty of air flow but I'm afraid of getting stuck in stop and go traffic.
If I direct wire it the fan does work so that's not it. I'm not sure where to start or what to look for. I tried searching here and google. I found some info about a relay in the driver kick panel that can burn out but no picture or exact location of it. looking for ideas and suggestions.
TIY
 
  • Sponsors(?)


HemiRick

I'd be looking at jacking under the house
Jun 28, 2020
764
288
73
58
Memphis TN
I dont think your elec fan is stock.....follow the wires....I know v8 cars had engine driven fans till at least 91
 

KRUISR

5 Year Member
Apr 16, 2015
920
349
83
51
The '87 and newer 4 cylinder foxbodies had an electric fan from the factory. Not good enough to cool a V8, but fine for a 4 cylinder.

1989 mustang lx 2.3L.gif

I would check out the Cooling Fan Temperature Switch and probably replace it.
 
  • Useful
Reactions: 1 user

KRUISR

5 Year Member
Apr 16, 2015
920
349
83
51
I seem to recall that back in the early '80s the 4 cylinder cars had a mechanical fan. Not sure if it was a clutch fan, likely more like the 60's and 70's cars and direct mechanical fans.

The factory e-fan is quite reliable. Back in the day I had an '88 and an '89 4 cylinder 5 spd. Neither ever had cooling fan issues. I would bet it is just the temperature switch (less than $10 on rockauto)

A quick question... is your temp gauge still working?
 

87LXVERT

New Member
Jul 5, 2021
5
0
1
60
East Greenwich, Rhode Island
The temp gauge does work. The PO probably removed the thermostat however because the car runs very cold in general. Haven’t opened that up yet to check. But sitting in traffic it will get hot and drop real fast once the car is moving with the air flow. So yes the gauge itself works fine
 

87LXVERT

New Member
Jul 5, 2021
5
0
1
60
East Greenwich, Rhode Island
I realized that the switch really just makes ground to turn the fan on. So I unclipped the wire and grounded it and the fan comes on. I would hope that's a good sign it is in fact the switch and not some relay I still have to track down.
So now I'm looking for a switch but none seem to list the temp on/off. I did find that it should come on about 10 degrees higher than whatever Tstat your're running which makes sense. So 205 would be correct. But.. again I don't see any with a temp listed unless it's standard?
 

KRUISR

5 Year Member
Apr 16, 2015
920
349
83
51
Fan switch on rockauto...


Gauge sender and engine temp for PCM on rockauto. Gauge sender has only 1 wire, engine temp sender has 2.

 

7991LXnSHO

wanna catch the space herp
10 Year Member
Sep 1, 2010
5,372
1,727
194
Kearney, NE
The electric fan will cool better at low rpm and take less power at high rpm than a mechanical fan. Switching to a mechanical fan would be a step backwards.
 
  • Agree
Reactions: 1 user

junkyardwarrior

Active Member
Jan 10, 2011
349
87
48
yup you're gonna have to dig out your electrical diagnosis skills. Surely, if you have dealt with German cars, you have this in your tool kit. Right? If not, you have two choices. (1) hire it out. Or (2) learn it. If you are into BMW's, you're far better off learning it.

The fan is ecu controlled. Meaning, the ecu senses engine temp, then it grounds the pin that goes to the relay (under the dash). Relay closes contacts and makes the fan motor hum.

So with that, you have possibilities. (1) ECU not sensing engine temp ;) (2) bad ground or bad wiring between ecu and relay. (3) bad relay. (4) bad fan. (5) bad fan (high current) wiring. (6) bad fan relay. More possibilities too but those are where you would be thinking.

You can do an EEC self-test and the fan is supposed to come on during the test. During the self-test you can check for codes.
 

KRUISR

5 Year Member
Apr 16, 2015
920
349
83
51
Actually junkyardwarrior, the 4 cyl fan is much simpler. As mentioned above, the 4 cyl cars have 3 temp sensors. One for the engine temp to ECU, one to the gauge and one for the fan. Each function independently. As the OP said, when he grounded the connector from the fan switch the fan came on. That to me would be the sensor/switch is bad. Change the sensor and back in business.
 
  • Like
Reactions: 1 user

KRUISR

5 Year Member
Apr 16, 2015
920
349
83
51
Could be, but the sensor in block triggers the ccrm. OP grounded the connector to that sensor and fan worked. Obviously the ccrm is fine and just the sensor is not working. My point was the 4 cylinder has a 3rd coolant temp sensor that is dedicated to the fan.