Erratic Idle And Sputtering Upon Acceleration

omnitech

New Member
Sep 4, 2014
5
0
1
22
Hello all I am having some trouble with my 1990 Gt with a mild 5.0 and 5speed. About a week ago my car started acting up. Idle surges, high idle up to 1900, sputtering upon take off and acceleration. And it's running very rich. I cleaned the MAF and it still does the same thing. But it's mostly after around 25-35 minutes of driving depending on how many times I have to stop. When I took off from a red light the other day it acted like it was going to stall and sounded like it had a 2 step. It was barely moving, but when it finally reached 2000 rpm it took off. This is normally a pretty quick car. Please let me know if anyone has had this issue and found a cure. Thanks for reading.
 
  • Sponsors (?)


jrichker

StangNet's favorite TOOL
SN Certified Technician
Mar 10, 2000
26,952
2,582
224
73
Dublin GA
You guys with idle/stall problems could save a lot of time chasing your tails if you would go through the Surging Idle Checklist. Over 50 different people contributed information to it. The first two posts have all the fixes, and steps through the how to find and fix your idle problems without spending a lot of time and money. It includes how to dump the computer codes quickly and simply as one of the first steps. I continue to update it as more people post fixes or ask questions. You can post questions to that sticky and have your name and idle problem recognized. The guys with original problems and fixes get their posts added to the main fix. :D

It's free, I don't get anything for the use of it except knowing I helped a fellow Mustang enthusiast with his car. At last check, it had more than 159,000 hits, which indicates it does help fix idle problems quickly and inexpensively.