Error Codes 512, 10, 121

paulguy122

New Member
Sep 26, 2021
3
0
1
21
Austin, Texas
I have a 1994 SN95 5.0L and I had some problems with the car. After bridging the EEC Test i found some codes and eventually got an obd1 ford scanner. The codes consists of 512, 10, and 121. The known issue I've had is throttle position sensor related. I replaced the TPS and i thought i had gotten an aftermarket part with different voltage readings so i bought another.
this third TPS hasn't fixed my issue and the car is idling at higher then 1250rpm. The car has a 70MM BBK Throttle Body and an Edlebrock elbow adapter for explorer heads. I'm not sure what to do at the moment as the code 121 mentioned bad tps voltage or possible MAF sensor. I'm not sure where to start and I was wondering if anyone could give me any pointers in the right direction.
 
  • Sponsors(?)


General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
20,718
7,128
203
polk county florida
What is the TPS reading?
have you done a base idle reset?
 

paulguy122

New Member
Sep 26, 2021
3
0
1
21
Austin, Texas
i have not done a base idle reset and i'm not sure how to read the TPS. I have a multimeter but i seem to have different color wiring in my harness.
I've seen that i'm supposed to read the tps with a green wire but all i see going into my tps are gray/gray white and ground
What is the TPS reading?
have you done a base idle reset?
I have a multimeter but I don't see a green wire. I have a 70mm BBK throttlebody and im not sure what wire I have to be finding the voltage from. I have not done a base idle reset im not sure how to do that