Fuel delivery problem..

Discussion in 'Other Auto Tech' started by Mike85000, Jul 17, 2007.

  1. Ok guys, after solving the ignition porblems yesterday with an 88 bronco II, we now have a fuel delivery problem.

    Fuel pump on frame is not running, doesn't prime when you turn the key, and the 2.9L won't run without fuel pressure.

    Pulled plug on the pump, no power there. Moved up to the relay, i can hear it click, and it is getting the power signal from the EEC relay.

    So it clicks but the problem is, it is not outputting any power to the wire that goes to the pump.

    So i check the fuse, its good.

    Basically the relay is not receiving it's main source power, it is being activated, but doesn't have any power to switch to the pump.

    Any ideas? It has power at the fuse, but no power supplies to the relay.

    I tried jumping a hot wire from the battery + to the relay input terminal, nothing, tried jumping the hot wire to the output (fuel pump) still nothing.

    Im running out of ideas other than jumping the fuel pump but i don't have wires that long and don't want to have to strip back the wires on the plug of the fuel pump.

    Any help is appreciated.
  2. Are you sure that it's not the relay, itself, that's defective? Wiring doesn't usually just go bad on its own - something usually has to pinch it, short it out, burn it, melt it, or otherwise cause some extreme damage to it to make that a primary issue (which is usually a matter of something else being catastrophically wrong).

    Are you checking to see if power is getting TO the relay from upstream, or are you checking it immediately AFTER the relay? If you're not getting power TO the relay, then you're going to have to manually trace the wire all the way back to the next link in the food chain and verify that there are no faults in the wire insulation, burn-throughs, kinks, pinched points, shorts, corrosion, or other physical damages. If you're not getting power FROM the relay, either find a non-essential relay of the same type on the vehicle that you can borrow (like the A/C system, for example) that you KNOW is functional, and see if that changes anything. There are also ways to check the relay, itself, with a mutlimeter, but I'm not quite in the know of that sort of electronic wizardry... :D

    Lastly, if it comes down to it, just spend a couple of bucks on a small roll of wire of a sufficient gauge (I'm guessing something like 14 to 16 gauge is what's being used), and run a fresh wire from the power source to the relay. SOLDER the connections if you splice it in - DO NOT use those crappy crimp connectors. If you still can't get power to the relay, then move farther upstream until you get to a point where you do have power, and work your way back down towards the relay and then the pump, again.
  3. FOund out my wiring diagram was wrong! THe colors they said went too the fuel pump relay actually were the colors going to the WOT AC cut-out relay.

    Turned out to be the inertia switch. I tested the fuel pump manually, good, then powered it from the inertia switch, then from the inertia switch plug that went into the mian harness, then nothing.

    New inertia switch and she was good to go (and yes I tried resetting it).

    Thanks for the help anyways, i was just about ready to wire in a new relay.