Fuel Fuel Leak after replacing fuel filter

Paradox2018

Member
Oct 9, 2019
24
4
13
21
Pennsylvania
I replaced the fuel filter in my 2001 Mustang gt for the first time and got everything reconnected (I think). When I turn the cars electric on to prime the fuel pump, there is a leak coming from the fuel filter/fuel filter area.

I can’t tell exactly where the leak is happening, but it’s definitely from around the filter area. Anyone have any solutions? Thanks in advanced
 
  • Sponsors(?)


PSKSAM2

Founding Member
Feb 13, 2002
716
4
18
NJ
mywebpages.comcast.net
Any chance there was damage to the connectors when you took off the old one?

Did the lines go all the way back onto the filter and click in?

Did you install the new filter in the correct direction of flow?
 
  • Like
Reactions: 1 user

Paradox2018

Member
Oct 9, 2019
24
4
13
21
Pennsylvania
Any chance there was damage to the connectors when you took off the old one?

Did the lines go all the way back onto the filter and click in?

Did you install the new filter in the correct direction of flow?

Sorry for the late reply, but I wanted to update this in case anyone else had the issue too.

It ended up being an o ring inside the quick connectors had fallen out when I took it off
 
  • Like
Reactions: 1 user

Paradox2018

Member
Oct 9, 2019
24
4
13
21
Pennsylvania
Good to hear you found it and I was pretty close, hope the feedback helped. Figured it had to be something like that, but wasn't sure on the guts of the connectors.

Ya it was a really simple fix and the feedback did help! I had a shop do it for me though as they were doing it for almost no cost and I'm pretty busy with college