fuel problems

Discussion in '2.3L (N/A & Turbo) Tech' started by HFK, May 29, 2007.

  1. The other day while warming up my '88 it shut off. It would not restart so I started to investigate. When I turned the key on there was no noise from the fuel pump priming. It did this about a year and a half ago and a new pump fixed it.

    I got a new pump, installed it and still, no priming noise. Next I replaced the relay and still nothing. It seems to have power going everywhere needed but no priming or starting. I shot some starting fluid (I know, not supposed to do on f.i.) and the engine catches and runs for a couple of seconds.

    Any ideas as to why it won't prime? Why would it start with fluid? Any one have any ideas I can try?

    Thank you.
  2. Weird. I would say that it's your relay, ut you replaced that. Here's something to try, pop the relay back out and make sure that there is power to the relay from the ignition switch with the ignition on. I have a feeling your ignition switch may be going out. Either that, or ensure that the fuel pump cutoff switch (black box with white button on it in the trunk, possibly behind the rear trim) has not popped. Just press the button and if it clicks, it was activated.
  3. I checked the cut-off switch right away. I had a new ignition cylinder and switch that I never put in so I tried them and still nothing. I'm running out of ideas.
  4. Real stretch, but maybe try a different ECU. I can't remember if they take over control of the fuel pump after the engine starts or not.
  5. First thing I would check is the EEC relay.

    The schematic I'm looking at is for an 89 but if the wires have the same colors then the Red/Green wire should get voltage when the ignition switch is turned to the run position, the Black/Orange wire should be hot at all times which is fed by a fusible link, and the Red wire should go hot when the ignition is turned to the run position.

    I had one of these relays go on my 88 merkur xr4ti and it did the same exact thing you describe.

    Other possible problems:

    fusible link feeding the EEC relay is bad
    ignition switch is bad
    bad wiring between relays
    bad ground at fuel pump (black wire)
  6. On the '88 is the fuel pump relay under the kick panel on the passenger side? This is the relay I replaced but is it the fuel pump or the eec relay? I don't see anything under the hood or anywhere else so I assumed this is the fuel pump relay but maybe not? Where else could it be or is this the only relay?

    I appreciate all the help and have been researching and I see all sorts of mention of a relay box under the hood but can not find any so is this the right relay for the pump or am I missing it?
  7. my 89 lx did the same . reach under driver seat and grab fp relay, turn key and no click. checked fueable links ok, open glove box and dig out eec relay just above computer. plug in new relay, then i got the audible click and fuel pump prime . starts up