Getting tired of chasing high idle problem

Black GT

Active Member
Sep 8, 2018
147
9
28
65
Jacksonville, Florida
I am just about to give up on my 2001 GT. It runs fine until it warms up to running temp. Once it get to half way on the temp gauge it idles around 2200 rpm. I have replaced the IAC with a new motorcraft one from Ford. I have checked the throttle return spring, replaced all the vacuum lines, cleaned MAF sensor and throttle body, sprayed carb cleaner around intake, throttle body and vacuum lines with no increase in idle and sprayed carb cleaner around all connections on the cold air intake with no increase in idle. I have been plagued with this problem for over a year now and the car is just not fun to drive anymore. There are no engine codes. When the problem first started I could turn the engine off and restart it and it would idle great for awhile and then start the high idle again. I am thinking it has to be a sensor that tells the ecm what to set the idle at or the ecm itself since turning off the car corrects the problem. Opinions are welcome as I am at wits end with this.
 
  • Sponsors(?)


Black GT

Active Member
Sep 8, 2018
147
9
28
65
Jacksonville, Florida
Finally after a year of chasing my high idle troubles I have it fixed. I found this throttle body assembly at our local upullit for $27. including tax. It came with the IAC and TPS and throttle body. Swapped it with the one that was on the car and car idles perfect now. Just took it for a long ride and idles just like it should. Not sure which one of the replaced parts was the problem. I don't think it was the IAC because the old setup had a new one from the Ford dealership. My car is fun to drive again.
 

Attachments

  • IMG_0434.jpg
    IMG_0434.jpg
    671 KB · Views: 17
  • Like
Reactions: 1 user