Guys!Help!Quick! My motor took a dump!

bluevenom867

I will have images of molesting stuffed animals in
Dec 15, 2003
1,704
1
0
St.Petersburg,FL
Visit site
We were going down the road ready to try out the new nitrous system for the first time.I did every thing right, purged,set the timing down,had good gas (110 octane),and a 125hp shot in.I was in second gear and floored it (it has a WOT switch) at about 4000rpms.The nitrous delayed and then came on quickly and hard at about 4200rpms, at this time the car was flyin' and I had a huge grin on my face.Then about a second after the nitrous came on the motor cut out.I shifted through second and first and gave it some gas, nothing.The motor didn't revv and was droping rpms quickly, I pulled over to the side of the road and tryed to start it. Noting it turned over but no start.It didn't make any sound when it went, no back fire, no clang, nothing.
Is tryed to start it again and noticed there was no oil pressure.I assumed my bottom-end took a dump and was in a bunch of pieces in the pan.But then I tought "wait,if the bottom-end is gone why do all the pullies turn?"At this point I then suspected I broke the timing chain or distributor gear as the motor didn't seem to be firing.I pulled the car back to my shop and left it there.At this piont I'am now trying to think of all the things that could have gone wrong.
Please tell me what you think.I need to get it fixed within a month and I dont have much cash.Thanks.
 
  • Sponsors (?)


TT91

New Member
May 23, 2003
1,536
0
0
36
Paramus, NJ
members.rankmyride.com
If your oil is purple or yellow, u may have a serious problem.... :rolleyes:


all jokes aside, start with the simple checks, spark, fuel, ect. Test the starter,Jump the starter solonoid. If your motor takes a dump, you know it, youll hear it, and most likely feel it. Timing chain seems like a good start.Definetly check you oil first for any type of debris. Then check your radiator for any signs of bubbles/ oil. good luck
 

bluevenom867

I will have images of molesting stuffed animals in
Dec 15, 2003
1,704
1
0
St.Petersburg,FL
Visit site
Ok I just wet to the shop, nothing serious.
I blew an ignition coil and the ticking sound I head when cranking was the coil arking.I was also loaded up on fuel and was trying to start the engine with the timing to low.
Thanks any how.
 

91StangLX

New Member
Mar 26, 2004
95
0
0
bluevenom867 said:
We were going down the road ready to try out the new nitrous system for the first time.I did every thing right, purged,set the timing down,had good gas (110 octane),and a 125hp shot in.I was in second gear and floored it (it has a WOT switch) at about 4000rpms.The nitrous delayed and then came on quickly and hard at about 4200rpms, at this time the car was flyin' and I had a huge grin on my face.Then about a second after the nitrous came on the motor cut out.I shifted through second and first and gave it some gas, nothing.The motor didn't revv and was droping rpms quickly, I pulled over to the side of the road and tryed to start it. Noting it turned over but no start.It didn't make any sound when it went, no back fire, no clang, nothing.
Is tryed to start it again and noticed there was no oil pressure.I assumed my bottom-end took a dump and was in a bunch of pieces in the pan.But then I tought "wait,if the bottom-end is gone why do all the pullies turn?"At this point I then suspected I broke the timing chain or distributor gear as the motor didn't seem to be firing.I pulled the car back to my shop and left it there.At this piont I'am now trying to think of all the things that could have gone wrong.
Please tell me what you think.I need to get it fixed within a month and I dont have much cash.Thanks.
Tryn these people they have 306 and 308 short blocks for a reall good price. I bought one and it is a superp shortblock very professionally done and the power I am getting is outstanding. They ship fast to.

http://cgi.ebay.com/ebaymotors/ws/eBayISAPI.dll?ViewItem&item=7915243107&rd=1&sspagename=STRK:MESE:IT
 

Similar threads