(HelpPlease)Weird slapping noise under valve cover after Cam Install+Rebuild, 2001 SVT Cobra Forged Rebuilt.

SVT_Yossii

Member
Mar 15, 2019
12
2
13
20
South Carolina
This is my 2001 SVT Cobra I have been working on for about 7 months. Engine about 0.030 Bored over, Crankshaft shaved .030/.030 K1. Technologies H-Beam Rods,,Kings XP Bearings, Ford Racing Timing Kit(A few timing components were upgraded from stock to Billet.) D.S.S Racing Pistons, Heads were redone and have Howard Cams+Springs/Retainers upgrade, 255 LPH Fuel Pump, Ford Racing 47# EV14 injectors*They are compatible plug and play with ev6*, SCTX4 Hand Tuner, Dan at ProDyno got me a first start tune for all my mods. Exhaust is BBK Long Tube Headers+BBK O/R H-Pipe + Stock Catback/Muffler. CAI Intake into the fender. BBK Twin 62mm Throttle Body, 1 Inch Intake Spacer, Exedy Mach 350 Stage 1 Clutch, BBK Adjustable Clutch Cable, Quadrant & Firewall Adjuster, Exedy Lightweight Racing Flywheel, MMR Ford Billet Rear Main Seal Housing cover, ON3P Coolant Cross Over Delete, MMR Light Weight Power Steering Pulley, MMR Head Cooling Mod, SR Lokar Flexible Dipstick---*If You Have Long Tubes, You Will Love This*, Ford OEM Coil Packs*I Heard OEM coil parks were reliable*,NGK Iridium IX Spark Plugs* Thinking about going to Copper Plugs and changing them more often*.

View: https://www.youtube.com/watch?v=DEW-CCrPrgQ

Just Watch this Video(This video shows the Driver side, Which Was at first making the noise, but has now gone quiet and the noise transitioned to the passenger side very front of the valve cover) .. The tune is probably not too good it was just put together and I uploaded it with my SCT x4. But he told me to bring it back to him as soon as I can and he can get a good tune with it on the dyno(under 4000 rpm). Maybe this is PTV issues(Time to pull all plugs and check for Visible dents from valves???). Maybe this is a stuck lifter, collapsed lifter or the lash adjuster isn't getting the oil it needs? Maybe its my Oil? Royal Purple break In convention oil 10w-30. Maybe the timing is off by a tooth? Or. Maybe the timing isn't degreed properly with the cams?. Or this sound is normal with what was done to my engine? When I drive it, it quiets down slightly and just blends in with the other noises. Every Pulley except A/C is new.
 
  • Sponsors(?)


Noobz347

Stangnet Facilities Maint Tech... Er... Janitor
Admin Dude
Jan 4, 1985
27,286
9,694
224
Box behind Walmart
www.stangnet.com
First, let me move this thread to a place where it'll find some traction. Lifter issues aren't specific to Cobras. :p

Next: Two things come immediately to mind... The valves are adjusted on the loose side --or-- the rockers (or whatever serves in this capacity) are making contact with the valve cover.
 

SVT_Yossii

Member
Mar 15, 2019
12
2
13
20
South Carolina
First, let me move this thread to a place where it'll find some traction. Lifter issues aren't specific to Cobras. :p

Next: Two things come immediately to mind... The valves are adjusted on the loose side --or-- the rockers (or whatever serves in this capacity) are making contact with the valve cover.
I'm thinking lack of oil pressure/oil passage clogged. Lifters not filling up( I don't think he soaked them before install), You can barely hear it while under the car so it must be top end noise right?? The noise goes away when any revving of rpm, only does it at idle. it also goes away for 2 seconds randomly then it will come back but be pretty quiet.

EDIT-- Changed my plugs today, Changed my Oil+Filter, Oil looked great, typical microscopic shavings in the oil nothing bigger. There was "sludge" on my magnetic oil pan bolt. I'm thinking it is just assembly lube washing off everything, I watched the guy build my engine+time it, that is why I don't get what it could be. He turned it over at least 15 times when building it, lubing it really really good, he checked for clearance in the oil pan and in the valve cover, no clearance issues, and no bounding when turning it over by hand.
 

Noobz347

Stangnet Facilities Maint Tech... Er... Janitor
Admin Dude
Jan 4, 1985
27,286
9,694
224
Box behind Walmart
www.stangnet.com
Will it still knock just off of idle? I mean at all?

I wonder if you might be onto something with the lifter idea. Your description of the symptoms are classic.
 

SVT_Yossii

Member
Mar 15, 2019
12
2
13
20
South Carolina
Will it still knock just off of idle? I mean at all?

I wonder if you might be onto something with the lifter idea. Your description of the symptoms are classic.
Today I started it up with its new oil change+filter and it didn't knock for the first 10 seconds afte that it slowly started knocking and was there in the background the entire time I was loading it onto the trailer I got today to bring it to pro-dyno to get tuned. But I might just be wasting 70$ on a trailer and driving it 25 minutes there to get told I need to take the valve cover off for inspection. :L

EDIT- Also, I tighted up my belt tensioner a little, it took no force to remove the bolt, tried tightening my water pump but the engine kept spinning., I did tighten smooth idler pulley more, didn't touch the grooved one
 

LaserSVT

I was N/A once, it was awful.
Moderator
Nov 29, 1999
7,936
2,127
233
In your computerz watching your pronz
The ticking? Thats injectors. Thats all I hear in that video. That being said those early C heads are known for guide issues on not only the timing chain but also the valves. Collapsed lash adjuster could also be to blame. Did you change the oil pump gears during this build?