Idle sputting and humping

Gone

New Member
May 2, 2020
5
0
1
22
Home
Hi! I've been wrestling with this problem for a while, car runs pretty good but idle is not good, RPM humping between 650-750 sometimes 750-900 and sputting from exhaust irregularly, bank 1 in, bank 2 out. parts already changed is: plugs, wires, coils, fuel pressure regulator, injectors, O2 sensors, heads compression tested, timing checked, tried to locate if there's any vacuum leaks without success(only hissing noise i hear a ten seconds is from somewhere near ABS pack after i shut engine off), clean TPS, clean ICM and tried PCV delete plate. Any change making no difference and running out of ideas..?

I drove car to emission test the other day and the test guy's opinion was the car was fine, but is it. What do you guys think from these values?>>>

at idle:
Co% 0,02%
Co2 14,10
HC 16
O2 0,70

Lambda 1,069

With revs:

Co% 0,04%
Co2 14,20
HC 16
O2 0,40

Lambda 1,016


ShortFT1 0,0%
ShortFT2 -1,6%
LongFT1 -12,5%
LongFT2 -8,6%
 
Last edited:
  • Sponsors(?)


StangNet created a new car social app called knowmoto! Add your Mustang or post a photo in the knowmoto app and enter for a chance at a $100 gift card from LMR. Click the LMR Logo for more about the knowmoto Mega Thread!

Gone

New Member
May 2, 2020
5
0
1
22
Home
Update: today checked my purge valve and hit it with 12volts and it not show any sign of life, did not click, even tru to block without any change. Multimeter shows about 0.40 and 0.90 ohms between purge valve ground and signal pins.
Also i noticed somethimes when car runs better MAF reading is 7.8g/s instead of rough idle reading 5.9g/s, in drive speed MAF reading is somewhere between 15-20g/s and under load 40g/s which i think is o
 
Last edited: