Intermittent Miss-fire Mystery

Discussion in '1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk-' started by saully, Aug 11, 2014.

  1. Ok guys. I have a REALLY strange misfire that I cant find. Nothing makes sense. I pride myself in being pretty good at fixing problems but this one would have me pulling hair out if I had any lol The ONLY things that seem to be the same when it happens are : After a highway cruise and coming to a stop it idles rough and misses terribly but if I accelerate again there is NO hesitation or evidence of a miss.....until I stop again. then, all on its own it will clear up a stop or two later. Once in awhile during highway speeds the car will buck once or twice the rpms drop and it picks back up like nothing happened at all. Cold starts and idles fine, sometimes with a slight miss in the exhaust. Does not smell rich, plugs look perfect. Here is a list of all items that have been changed and or swapped with new parts because I have checked EVERYTHING I can at this point and it is still there. I'm just gonna list everything done to the car.
    Checked and crimped black and white connectors
    Checked all grounds
    Timing set at 12 degrees advance (tried it at 10 14 16 as well)
    Checked vacuum routing and for leaks
    Idle relearn procedure
    Checked wire harnesses/connectors
    fpr holds vacuum, no smell of fuel
    coast down relearn (dropping from 60 to 40 mph)
    NEW plugs. wires. coil, cap rotor, act sensor, gt40p heads (new), explorer intakes and tb, shorty headers, fuel pump, fuel filter, egr valve (egr valve has since been deleted with a dummy plug installed), maf upgraded to 70mm with matching sensor, 130 amp alternator, electric fan, injectors, distributor (complete with hall effect etc.), tfi module (tried 2), o2 sensors, coolant temp sensor, iac, tps (voltage at .98, tried several different voltages just cause), and.....that's probly it, may have missed something

    There are NO codes. koeo, koer, cylinder balance test passes every time, I will add that when you turn the key on for the test the cel flickers a few times before flashing 11 so idk if that's normal

    This problem has persisted before and after all items were changed/tested/etc.

    All I can think of at this point is a fault in the pcm

    Sorry for the long write-up but I wanted to be thorough, and yes I have replaced a lot out of anger, frustration and lets not leave out stupidity.

    I give up!!!!!