is anything wrong with tune or is it my car ???

Jimmer009

Member
Jan 4, 2022
21
2
13
42
Ny
hi all, I have a 91 gt. I have speed master aluminum 190cc heads, x303 cam msd 6al and a blaster coil, 75mm throttle body and 42# injectors. I just put new plugs autolite 25's in. new intake and exhaust gaskets. I had a skip which was cylinder 4 injector not plugged in oooppppssss. but it is now. the car still hesitates and every time around 4000 rpm it skips then keeps climbing.

I have megasquirt 2 v3.57 ill post a log here of me idling and holding the rpms at just under 2000. does anything seem bad???

also any tips on setting up me7 logger??? I have a hard time making changes to my tune after reviewing the logs.

thank you every one for any help
 

Attachments

  • 12skipafew678.msq
    119.4 KB · Views: 0
  • log14.mlg
    251.1 KB · Views: 0
  • Sponsors(?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,634
6,827
214
33
Hillsborough county
I'll take a look when I have a moment.
25s are a bit hot, you should be using a 3924.
Besides the skip what issue are you having
 

Jimmer009

Member
Jan 4, 2022
21
2
13
42
Ny
The skip is biggest issue. I'm thinking it's hardware related. The misfire at 4000 rpm has been there awhile. I'm thinking that is software related. Idk. The cam and heads are little big and I'm lower on vacuum than I hoped.

I'll get the new plugs. But any chance when the msd box goes from 2 sparks to 1 at higher rpm it's throwing off the tfi???
 

Jimmer009

Member
Jan 4, 2022
21
2
13
42
Ny
Ok. Thanks. I just got the 3924 plugs. I won't get them in till tonight but. There way different than the 24's. I'm betting that is my issue. Witch thanks for that help. And sorry for the dumb question on the tfi. I have tryed researching it and didn't get very much info.
 

Jimmer009

Member
Jan 4, 2022
21
2
13
42
Ny
So the new plugs did the trick. Amazing what the part will do. I still got a skip at 4000. But I found I'm leaking oil out of the back it. So I'll get that get new gaskets. But I'm leaning towards that might be in my distributor. Its probably the stock one and just ready to be changed.