JCBeaver's 1993 GT Coyote Swap "The Never-Ending Project"

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Give this a try
You really do know your :poo:.....

It idled the best it ever did under my ownership haha. Minimal idle surging. Surged more at cold start up then it seems to settle down nicely. However it does buck around a bit under small loads driving around the neighborhood and then I did open her up quite bit on the 2nd log before my computer crashed, hope the log caught some of it. I think it did ok, a little miss here and there but for the most part it was good. Let me know what did you think.

1st log is warming up.. driving around the neighborhood then 2nd log i went out on the backroad for a bit which should have a quick semi wot logged.
 

Attachments

  • 2020-01-04_18.55.31.msl
    2.4 MB · Views: 89
  • 2020-01-04_19.02.12.msl
    1.2 MB · Views: 71
  • Sponsors (?)


a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,683
6,881
214
Ok so some areas needed fuel removed, I of course over complicated things for you... I made up two tune revisions the first will be standard, the second may make seans head explode.. and hopefully fix the odd idle behavior and any bucking.
 
  • Like
Reactions: 1 user

JCBeaver

Active Member
Mar 23, 2018
124
70
38
10-4

So which one do you suggest me to run? I am assuming the 2nd one considering it has your tricks on it ;) I guess you are just trying to help Sean see what tricks you threw in? I might as well learn too haha!

Thanks so much! I ll report back with a new log
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,683
6,881
214
Yes use 1.0.2 as a first run, if it does not idle correctly then please run 1.0.1

1.0.2 has some large changes to it, sometimes they take a few tries to get correct... BTW I am just using some of my base tune settings for a blower cammed engine, nothing earth shattering. then we tweak until done.
 

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Oh I also wanted to ask if I could activate the meth injection pump from my MS? I know it is possible but we never figured out how to use the tables. Will you be able to help out on that? When I get am ready to add meth after confirming the set up runs good as is

edit: i have the stupid boost switch on there for now and i would love to eliminate it. I wired up from my ecu only to run into walls so i gave up and threw the boost switch on. I can wire it up no problem. just need help with switching it on from MS

edit2: actually i had to wire it up to boost control wire I believe since I am not using this feature on my PIMPXS ECU per Stinger's instructions. I never could figure out how to toggle the pump on and off from the boost control table.
 

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Rather than drawing up my own diagram I just snapped pic of my snow meth instruction.

I have it wired up that way. Now I am going to route the COM wire to Pin 31 on my PIMPXS ECU which is labeled as the “boost” pin. It has to be activated by adding a jumper to JP9 which I have already done so. Just unsure how the hell am I supposed to activate this pin.
The guys from Stinger support likes to give very minimal answers to make me keep digging.
 

Attachments

  • E6BA70E0-519D-4923-8D4F-01C2FA2CC4B6.jpeg
    E6BA70E0-519D-4923-8D4F-01C2FA2CC4B6.jpeg
    358.2 KB · Views: 75
  • 7FC29E45-C3E7-4A70-8433-C91E66D881AD.jpeg
    7FC29E45-C3E7-4A70-8433-C91E66D881AD.jpeg
    309.4 KB · Views: 73

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,683
6,881
214
Rather than drawing up my own diagram I just snapped pic of my snow meth instruction.

I have it wired up that way. Now I am going to route the COM wire to Pin 31 on my PIMPXS ECU which is labeled as the “boost” pin. It has to be activated by adding a jumper to JP9 which I have already done so. Just unsure how the hell am I supposed to activate this pin.
The guys from Stinger support likes to give very minimal answers to make me keep digging.
yeah... but wired that way it wont function... The boost pin supplies ground to the relay from the ecu... NOT 12v+

looking at a typical 5 pin bosch relay...
pin# 85- ECU boost pin
#86 - 12v+ ign source [must be off when ecu is off]
#30 - 12v fused power from the battery
#87- To the Pump
 

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Is this how I should do it?


looking at a typical 5 pin bosch relay...
pin# 85- ECU boost pin
#86 - 12v+ ign source [must be off when ecu is off]
#30 - 12v fused power from the battery
#87- To the Pump

Guess I will be paying auto store a visit tomorrow to grab a 5 pin relay.

edit: man I am an idiot lol. I already have the 5 pin relay from my current set up. I’ll just change up the config per your instruction. Thanks. I suppose we will wait on meth’s addition in the tune until I can confirm the engine runs properly.
 
Last edited:

JCBeaver

Active Member
Mar 23, 2018
124
70
38
OK I have it all set now. Ready to use meth kit when turned on in the tune :stir::crazy:

I am running just 7 psi pulley for now and I understand that it is recommended to turn on the meth at halfway point of the full boost I am running. which is around 3-4psi, is that the correct way to do it?

Thanks again for the guidance!
 

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,683
6,881
214
With your blower you want the meth on at almost full boost switch point. The reasoning is your boost level is like an on/off switch, you have to play the throttle in order to see partial boost.

Dont worry I have lots of experience with pd blowers.
 
  • Like
Reactions: 1 users

JCBeaver

Active Member
Mar 23, 2018
124
70
38
With your blower you want the meth on at almost full boost switch point. The reasoning is your boost level is like an on/off switch, you have to play the throttle in order to see partial boost.

Dont worry I have lots of experience with pd blowers.
Can you elaborate further? Do you mean I shouldnt want meth to come on until my boost reaches its full capacity? Not exactly understanding what do you mean by on/off switch? Forgive my ignorance :)

I will be taking it out for another spin shortly!
 

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Got it.

Here is a couple of logs for you which was ran with 1.0.2 Map. Ran rather well. Had a lot more punch this time considering it wasn't too rich all the time. It had more punch in 1st and 2nd gear, but not sure about 3rd under the heaviest load. May be tad bit too rich still. Log should tell us what happened.

The idle started to swing around a little towards the end when engine is plenty warm. Also, when cruising back to home, it seems to running a little on the lean side.

I saw some smoke coming out of the cowl hood when I pulled into my driveway. Turns out my PCV valve fell out of the PCV port at back of the intake.. did it get blown off? I guess I will find out more later on. Is this normal?

Let me know what do you think. Thanks again!

edit: I have a PCV Valve on back of the intake, which has a tube connected to inlet tube of the blower.. I also have the oil filler tube breather connected to the throttle body. Let me know if I should have a different set up arranged. The nipple on my oil filler neck is stripped off so I need to tap a new one in to ensure it is sealed. I suppose that can affect vacuum issues?

edit #2: The PCV valve and grommet I have slides in and out the port on the intake easily. I am reading that it should be a rubber grommet and it should be snug. What I have feels like plastic or mixed material of some kind. Should I just slap RTV around the grommet and put it in? And do I need a PCV valve for a turbo/SC application?
 

Attachments

  • 2020-01-05_08.40.35.msl
    1.4 MB · Views: 72
  • 2020-01-05_08.49.06.msl
    1.4 MB · Views: 70
Last edited:

JCBeaver

Active Member
Mar 23, 2018
124
70
38
Just went out to try to drive it to the food store but as i got out of the driveway it starts to idle hunt and bucking around. Engine is already all warm from the drive less than an hour ago. And just driving around the block, AFR was reading closer to 15.
 

Attachments

  • 2020-01-05_09.41.33.msl
    301.4 KB · Views: 84

a91what

SendMeUrDataLog
Mod Dude
Apr 6, 2011
10,683
6,881
214
When you get datalogs take them for the entire trip, start the log before you start the car and end it when you shut the engine down.

Just got done taking a look, the car was not warmed up in these logs, when i went to filter the data it junked 95% of the log file. I cannot do anything with them.
 
  • Like
Reactions: 1 user