Progress Thread Left me stranded, again... just luckily it was in the driveway.

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
Are you gonna try to change the pip sensor? I just bought a reman distributor. I think it was only $58 from summit. Make sure it’s the steel gear one.
Yeah I bought a new distributor from autozone, I know they don’t have great reviews but no way for me to have access to a puller or press but I’ll keep it and maybe just try and rebuild it to have as a back up Incase this new poops out, really want a hot forged dyna mod but don’t feel like dropping 275. Anyways popped the new one in, had a buddy help me with the timing. Car fired up, now I just need to go take it for a cruise and see what happens, once it gets warmed up and see if it cured the problem.
 
  • Like
Reactions: KZGUNS
  • Sponsors(?)


Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
Well guys took her out for a cruise today for about 30-45 minutes. She ran great, no check engine light popped on. Thanks to everyone who chimed in and helped me figure this out. Only random thing it did was it turned of twice at two different lights but started right back up. Not sure why it cut power, just turned off and gave me the battery light. Just glad i was able to get her out and drive and get past the check engine light issue by fixing the distributor.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
So as you all know I was having the weird check engine light, car died etc. so replaced the distributor, had a friend check the timing prior and then set it back to what it was from what the guys who tuned the car had it set at. So basically pulled the old one out, in with the new, set timing and that’s all we did. So drive the car yesterday and today, driving running fine, pulls good, car is warmed up but not bad thanks to the fans. Well just like yesterday I pull up to a stop, throw it in neutral, car starts to idle like normal right at 1K, it fluctuates a little then bang shuts off, get the battery signal. Crank crank cars fires up and I’m off. Get to another light, same thing idle at 1k, fluctuates but this time, check engine lights flashes, goes away, I hit the gas to keep it going and make it to the shop for inspection, roll in car shuts off and battery signal again. I noticed after picking it up from the tune, it would idle perfect but if you give it gas it would rev up, come down but stick at 1500 for a bit then drop back to 1k. The guys at the tune shop said my IAC is probably going bad. Anyways I have this high pitched noise which I recorded, that doesn’t come on right away but after a few minutes it starts up so I recorded it. I also got a quick shot of the car pulling into the garage, and doing the shut off thing but strange thing is the check engine light also came on. Haven’t ran the obd 1 scanner to see what it was yet.
View: https://youtu.be/1AAp1yTckA4

View: https://youtu.be/YJE-Iq3UyTE
 

KZGUNS

I can swing up to 11”
Jul 23, 2018
629
259
73
43
chardon, Ohio
Unplug the iac and see if the sound goes away. I will say if you replace it, get a motorcraft iac. I got mine on amazon believe it or not and it was the best deal.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,243
4,321
203
42
Sounds like the famouse throttle body whistle. It's all over the interwebs. My car did it until the latest set of tunes from the great Steve.

The rpm is set in the computer or chip. The IAC opens and closes to help regulate that rpm.

Example, a small vacuum leak will cause higher rpms because of extra air getting in the engine....the computer sees the rise in rpm and tries to compensate by closing the IAC " idle air control valve ". It does this at coming to a stop and at idle.

Do you still have the " salt and pepper shaker " harnesses at the back of the intake ? I've found that cleaning those connectors with electrical cleaner spray help with a bunch of different problems.

It6s tough to give advice because the car was recently tuned. Cutting off in both situations is an idle control issue. There are several factors for idle control. Thinking could also do it... but im assuming your friend knows how to set it properly with unplugging the pip and resetting the TPS. Did they give you any info for the tune... like cold idle rpm and warm idle ?

You could probably band aid it by tweaking the mechanical idle a little bit to keep it from cutting off.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,416
5,237
193
polk county florida
I agree on the 'ringing', it may go away but I doubt it, some have had success taking the sharp edges off the iac and egr opening but don't count on it, I can blip my throttle and make it whistle dixie. I think adjusting your tps is a waste of time but thats me, what was the reason you had it 'tuned'?
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
What code is it showing?
I will have to try that, what happens when you do it? Is it suppose to stay on? Shut off? So I ran the scanner, of course I had not cleared/dumped the codes so got the same ones I had previously but also got a code 96 last night.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
Sounds like the famouse throttle body whistle. It's all over the interwebs. My car did it until the latest set of tunes from the great Steve.

The rpm is set in the computer or chip. The IAC opens and closes to help regulate that rpm.

Example, a small vacuum leak will cause higher rpms because of extra air getting in the engine....the computer sees the rise in rpm and tries to compensate by closing the IAC " idle air control valve ". It does this at coming to a stop and at idle.

Do you still have the " salt and pepper shaker " harnesses at the back of the intake ? I've found that cleaning those connectors with electrical cleaner spray help with a bunch of different problems.

It6s tough to give advice because the car was recently tuned. Cutting off in both situations is an idle control issue. There are several factors for idle control. Thinking could also do it... but im assuming your friend knows how to set it properly with unplugging the pip and resetting the TPS. Did they give you any info for the tune... like cold idle rpm and warm idle ?

You could probably band aid it by tweaking the mechanical idle a little bit to keep it from cutting off.
Ok so those I believe are taken out. So run down of the distributor change goes like this. So checked timing with PIP out, which he use to work at the shop and he remembered having the timing at 14, but after the tune the timing was set at 9. Got it TDC, loosened the screw, pulled the old one out, dropped the new one in and got it aligned properly. Replaced the rotor and cap, tried to fire it up and it was a struggle at first, gave some gas and it fired up. Started to adjust timing and the tfi module it came with broke. So took the other tfi I bought and slapped on. Cranked it on, again a little struggle but it turned over, set the timing back to what it was, plugged the pip back in and it idled at what it was prior. Let it just idle for about 10-15 minutes and that was it. Didn’t do anything with the tps sensor. What should I do with that? As for cold hot rpm idle I didn’t get any of that info as I was just excited to pick up the car and go fast.
 
  • Like
Reactions: 90sickfox

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
Sounds like the famouse throttle body whistle. It's all over the interwebs. My car did it until the latest set of tunes from the great Steve.

The rpm is set in the computer or chip. The IAC opens and closes to help regulate that rpm.

Example, a small vacuum leak will cause higher rpms because of extra air getting in the engine....the computer sees the rise in rpm and tries to compensate by closing the IAC " idle air control valve ". It does this at coming to a stop and at idle.

Do you still have the " salt and pepper shaker " harnesses at the back of the intake ? I've found that cleaning those connectors with electrical cleaner spray help with a bunch of different problems.

It6s tough to give advice because the car was recently tuned. Cutting off in both situations is an idle control issue. There are several factors for idle control. Thinking could also do it... but im assuming your friend knows how to set it properly with unplugging the pip and resetting the TPS. Did they give you any info for the tune... like cold idle rpm and warm idle ?

You could probably band aid it by tweaking the mechanical idle a little bit to keep it from cutting off.
Also I’m use to the tb whistle while I’m driving and punching the peddle but never heard the loud whistle ringing while it is just idling.
 

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,243
4,321
203
42
With just the distributor swap you shouldn't have to adjust the tps. The idle screw also shouldn't have to be messed with. If the timing is exactly where it was previously then it should run exactly the same is when you first left the tuner.

I really wish I could help you more but it seems like you may have an underlying issue. Sounds like your friend did the timing adjustment right. The iac could be the cause of this issue but it wasn't the root cause of the cut off and wouldn't restart issue. Hard to imagine all these parts going bad at one time.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
I agree on the 'ringing', it may go away but I doubt it, some have had success taking the sharp edges off the iac and egr opening but don't count on it, I can blip my throttle and make it whistle dixie. I think adjusting your tps is a waste of time but thats me, what was the reason you had it 'tuned'?
I had it tuned bc I put heads, intake, bigger tb, injectors, pro m mass air, gutted the smog system, all new exhaust, bigger fuel pump. So it was running like crap and needed to be tuned up.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
With just the distributor swap you shouldn't have to adjust the tps. The idle screw also shouldn't have to be messed with. If the timing is exactly where it was previously then it should run exactly the same is when you first left the tuner.

I really wish I could help you more but it seems like you may have an underlying issue. Sounds like your friend did the timing adjustment right. The iac could be the cause of this issue but it wasn't the root cause of the cut off and wouldn't restart issue. Hard to imagine all these parts going bad at one time.
So I did check the codes even though I didn’t dump the codes, so got the same ones a previous but this time I did get a code 96. Not sure if that has anything to do with it. When the car would shut off coming up to a stop or just sitting at the light like I said it would drop idle and shut off, show the battery sign. I would crank it but it would crank for a minute, I’d give it some gas and it would start up. I’m gonna crank it this afternoon when I get home and see what it does and then try unplugging the IAC and see what happens. I’ll record it and post it. I’m not sure what it’s suppose to do when you unplug it though while idling.
 

FoxMustangLvr

I love my Pimp
SN Certified Technician
Oct 14, 2012
4,971
3,507
194
44
Spokane, Wa
Correct me if I'm wrong but the IAC only works when the engine is cold. If the stalling is happening while the engine is warm then it's not the IAC. It could be a vacuum leak or it could be in the tune, stall saver timing, fuel cut on decel, etc. Sorry to say Omar but this is where it benefits you to have a stand alone ECU like Stinger or Megasquirt, we (err Steve) could help you out with that. Another benefit is being able to plug a laptop in to your ECU and seeing all of your system information for analysis.
 
  • Like
Reactions: 90sickfox

Reddevil91

10 Year Member
Mar 3, 2010
1,318
519
153
Correct me if I'm wrong but the IAC only works when the engine is cold. If the stalling is happening while the engine is warm then it's not the IAC. It could be a vacuum leak or it could be in the tune, stall saver timing, fuel cut on decel, etc. Sorry to say Omar but this is where it benefits you to have a stand alone ECU like Stinger or Megasquirt, we (err Steve) could help you out with that. Another benefit is being able to plug a laptop in to your ECU and seeing all of your system information for analysis.
Might have to look into that but I’d have no idea what to do with all that tuning stuff but I guess that’s how you learn.
 

stanglx2002

CT Material here
Mod Dude
Jul 7, 2005
1,369
906
154
Code 96 – KOEO- Fuel pump monitor circuit shows no power - Fuel pump relay or battery power feed was open - Power / Fuel Pump Circuits. The fuel pump lost power at some time while the ignition switch was in the run position.

This means you are having issue with the Fuel Pump relay. In your year model it is under the MAF, so it is exposed to hot/cold all the time. It is probably going bad, and once it warms up making it have issues.
 
Thread starter Similar threads Forum Replies Date
LarsD Lx Left Me Stranded Again Fox 5.0 Mustang Tech 44
O Engine 89 Lx Died And Left Me Stranded Today Fox 5.0 Mustang Tech 8
U2SLO450 my car left me stranded Fox 5.0 Mustang Tech 5
Adam95GT Car Left Me Stranded... UGH! HELP!!! 1994 - 1995 Specific Tech 98
PoopDawg Car left me stranded for the first time ever today... 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 5
F 89 5.0 firing on left bank only. Need ideas Fox 5.0 Mustang Tech 13
C my mechanic Swapped a 99 5.0 explorer 302 into my 94 5.0 left a much of stuff disconnected and abandoned it HELP!!! 1994 - 1995 Specific Tech 15
G Odd shaking on left upper side 1996 - 2004 SN95 Mustang -General/Talk- 4
M My Dad left me a yellow 67 rust bucket :) The Welcome Wagon 1
2 Brakes Right front and left rear brakes locked up. Classic Mustang Specific Tech 6
M Why is my left turn-signal light always lit?!! Fox 5.0 Mustang Tech 8
M Does anyone know what the hole to the left of the oil pressure sender is for?? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 6
Dustin2v Electrical 2001 GT - Left Sequential Taillight not working SN95 4.6L Mustang Tech 1
S Left blinker stays on with running lights. SN95 4.6L Mustang Tech 11
B 2004 Squeaking and Squealing when I turn wheel left or right The Welcome Wagon 1
B Sticker inside left door jamb SN95 4.6L Mustang Tech 1
R Noise coming from rear left wheel. Getting mixed information from facebook 1996 - 2004 SN95 Mustang -General/Talk- 1
67coupe Progress Thread 67coupe’s 89 LX - One paint session left!!! 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 301
C 1966 left front brake locks up when I radio the brakes Classic Mustang Specific Tech 3
The Shemdogg No left turn power steering 1965 - 1973 Classic Mustangs -General/Talk- 4
B sticking left front brake 1996 - 2004 SN95 Mustang -General/Talk- 9
true01blueGT 2003 mustang gt only left driver tweeter 1996 - 2004 SN95 Mustang -General/Talk- 1
F Humming In The Front Left Of Car 2005 - 2014 Specific V6 Tech 0
G Expired 1970 Mustang Front Left Clip $250 Interior Exterior Parts 0
J Wheel/tire Shakes Bad When Turning Left At Hwy Speed Please Help! 2005 - 2014 S-197 Mustang -General/Talk- 5
Slo5Oh89 Front Left Sagging Fox 5.0 Mustang Tech 6
TheFleshRocket Help! Attempting To Troubleshoot Mach 460 Front Left Tweeter Not Working. Mustang Sound & Shine All 1
9 Aunt Passed And Left Me Her Mustang... What To Do 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 47
teebluestang Fuel Gauge, Speed O, And Left Turn Signal Fox 5.0 Mustang Tech 1
dr. Dan W. Greetings From Way Out In Left Field! The Welcome Wagon 4
MCF84 Expired 2015/2016 Mustang Left Side Hood Vent Interior Exterior Parts 1
Jordan Warta 1995 5.0 Making Creaking Noise With Hard Left Turns? 1994 - 1995 Specific Tech 0
Joshuaachury Brakes Pulling Left When Braking And Random Scrapping Noise When Turning! SN95 V6 Mustang Tech 1
stykthyn Left Bank Exhaust Cold Fox 5.0 Mustang Tech 5
J Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 5.0 5 Speed Gt 1994 - 1995 Specific Tech 5
J Newbie Here. Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 Gt The Welcome Wagon 0
mpcv2000 Electrical Doing A "wire Tuck" On A 93 Lx. Left Frame Rail Side Harness Blk/wht 2 Into 1 Goes Where ? Fox 5.0 Mustang Tech 5
skiwesser11 Dumb Q: Would I Know If Pilot Bearing Was Left Out? Fox 5.0 Mustang Tech 8
C Expired 94-98 Left Rear Brake Caliper - A1 Cardone - Never Installed Wheels Tires Brakes 0
HexMora Rear Right Tire Sticks Out More Than Rear Left Tire. Fox 5.0 Mustang Tech 5
7 88 Gt No Brake Lights/ No Left Rear Turn Signal 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 3
M How Do I Be Left Alone In My 73 Mustang? 1965 - 1973 Classic Mustangs -General/Talk- 19
65Rob Left And Right Control Arms? Classic Mustang Specific Tech 2
M Mach 460 Left Side Not Working 1996 - 2004 SN95 Mustang -General/Talk- 5
Toolmaan 88 Mustang Rust On Frame Rail Below Left Shock Tower Fox 5.0 Mustang Tech 2
Busamike 1965 Fastback 347 Stroker, Whit Smoke Out Of Left Exhaust? Classic Mustang Specific Tech 3
B Help Build A 302 For A Sand Rail Using Left Over Parts... 1965 - 1973 Classic Mustangs -General/Talk- 6
GoldenEagle91 Suspension Clunk When Turning Left Fox 5.0 Mustang Tech 8
MRaburn 2015 Ford Mustang Convertible Enters Stage Left StangNet Site News 0
90lxwhite Any E7 Guys Left Out There? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 37
Similar threads