Progress Thread Left me stranded, again... just luckily it was in the driveway.

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,208
4,283
203
42
What is your idle rpm at ? Might need to tweak it up a little. The tps will need to be set again after that. You'd be surprised what a couple hundred rpm can do. Definitely check for vacuum leaks though.
 
  • Sponsors(?)


General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,262
5,184
193
polk county florida
With the engine idling and warm spray brake cleaner around the base of the intake gasket and where the upper and lower intake meet. Also any vacuum lines including the vacuum tree and the plastic lines that run along the firewall. Around the brake booster and the throttle body and egr plate. Test the egr to see if it holds vacuum.
Oh, have you checked for codes?
 

Reddevil91

10 Year Member
Mar 3, 2010
1,315
516
153
With the engine idling and warm spray brake cleaner around the base of the intake gasket and where the upper and lower intake meet. Also any vacuum lines including the vacuum tree and the plastic lines that run along the firewall. Around the brake booster and the throttle body and egr plate. Test the egr to see if it holds vacuum.
Oh, have you checked for codes?
Haven’t checked codes but I can surely do that. So with brake fluid I just spray it on there and I’m guessing look for bubbles?
 

Reddevil91

10 Year Member
Mar 3, 2010
1,315
516
153
Picked up a brand new eibach rear sway bar off FB market for 120 so couldn’t pass. Slapped that sucker in last night and started to snoop around the engine bay to see if I could find anything out of the ordinary. I think @General karthief asked about the egr valve then remembered last night I deleted and blocked it off as well as all the smog stuff. I found this vacuum line to which I’m not sure what it’s for but maybe it was hooked to the egr? You can see the line and it runs back behind the brake booster. I also noticed this plug on the back of the lower intake, I am not sure if I knocked it out or if it was already out but i plugged it back in and it’s not very secure it just easily flops out with out any effort. @90sickfox asked about my idle and since I’ve gotten it back from the tune it’s always idled right at 1k, will hold at that and doesn’t fluctuate. My next step will be to try and spray the brake cleaner around the intake etc and see what happens. I checked the codes and what I got was 15, 67 o, 85 o, 10, 29c, 66c, 96c. From what I gather the first 3 are the key on codes found, then 10 is meaning the end of what it found and last 3 are constant memory codes found. Like I said car starts and runs fine, I can run out and cruise for awhile then I’ll get to a random light, sit in neutral idling and I can just tell it’s gonna happen. It will idle funny, kinda fluctuate, I’ll here this loud whistle sound and it will turn off, unless I rev it and get moving again then it runs and drives and at this point I try and time lights so I make it through them and get back home. Could it be a heat soak issue with the tfi? I’ve seen more ppl doing these tfi relocation kits.
99AD615D-C3A9-4762-8732-C9A7DD2BFAFE.jpeg
685775FC-4FF3-4E97-9024-3BE7845ABDBE.jpeg
37CB72BF-2E15-43A8-A26A-2E25C7284AFE.jpeg
EB86192A-072C-4A9B-9054-E44EECB4B4A3.jpeg
E605A88A-6F69-41E2-BD0F-3F25EF75AE1D.jpeg
 
  • Like
Reactions: 2Blue2

Reddevil91

10 Year Member
Mar 3, 2010
1,315
516
153
Is that line your washer fluid line? Looks like it’s running over that way.
Guess that could be idk I don’t run my wipers and only reason the motor is back in it’s place is bc I was gonna reconnect it for inspection.
 

Rdub6

Mustang Master
Dec 29, 2017
1,317
970
123
Long Island, NY
Guess that could be idk I don’t run my wipers and only reason the motor is back in it’s place is bc I was gonna reconnect it for inspection.
And the connector went to the EGR valve that’s no longer there, from what I can see.... or is it the other end of your TPS harness. Hard to tell if the other half of TPS is there in the pic.
 
Last edited:

90sickfox

I didn't really have an issue with the stink...
SN Certified Technician
Mar 2, 2015
5,208
4,283
203
42
That thing in the last few pics is the pcv valve and should be stuck into the lower intake it goes down in the center between the firewall and the upper intake. That being out can cause issues. The replacement grommets don't fit well at all.
 

General karthief

wonder how much it would cost to ship you a pair
Mod Dude
Aug 25, 2016
16,262
5,184
193
polk county florida
Did you say you had it 'tuned'?
Does it have cruise control?
The rubber grommet for the pcv looks kinda oily, clean it and use some rtv to seal it back into its hole, also check the screen under it.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,315
516
153
That thing in the last few pics is the pcv valve and should be stuck into the lower intake it goes down in the center between the firewall and the upper intake. That being out can cause issues. The replacement grommets don't fit well at all.
Yeah it’s not the original, I ordered a new one when I swapped intakes and like I said it’s not tight. It easily just comes out, not snug at all.
 

Reddevil91

10 Year Member
Mar 3, 2010
1,315
516
153
Did you say you had it 'tuned'?
Does it have cruise control?
The rubber grommet for the pcv looks kinda oily, clean it and use some rtv to seal it back into its hole, also check the screen under it.
Yup it was tuned and has a SCT chip in it. I took it to a shop and they then took it for me out to McKinney tx at True street motorsports. I do have cruise control but since I swapped to a momo wheel that is gone now but I didn’t do anything but take the old airbag wheel off and put this one on after the tune was done. So rtv the grommet ok bc that think literally isn’t snug at all which I would guess it’s suppose to be. I noticed it seemed oily as well, is that bad?
 

Boostedpimp

10 Year Member
May 8, 2003
982
313
94
NJ
Reddevil91 said:
643181[/ATTACH]
DA71D119-AE6F-4236-8B33-BBFA5159B568.jpeg
F751F190-BCE3-4B15-9E9E-3B4671F51171.jpeg
FAB9FDF8-35CA-4083-A993-1E43EF288F65.jpeg
Picked up a brand new eibach rear sway bar off FB market for 120 so couldn’t pass. Slapped that sucker in last night and started to snoop around the engine bay to see if I could find anything out of the ordinary. I think @General karthief asked about the egr valve then remembered last night I deleted and blocked it off as well as all the smog stuff. I found this vacuum line to which I’m not sure what it’s for but maybe it was hooked to the egr? You can see the line and it runs back behind the brake booster. I also noticed this plug on the back of the lower intake, I am not sure if I knocked it out or if it was already out but i plugged it back in and it’s not very secure it just easily flops out with out any effort. @90sickfox asked about my idle and since I’ve gotten it back from the tune it’s always idled right at 1k, will hold at that and doesn’t fluctuate. My next step will be to try and spray the brake cleaner around the intake etc and see what happens. I checked the codes and what I got was 15, 67 o, 85 o, 10, 29c, 66c, 96c. From what I gather the first 3 are the key on codes found, then 10 is meaning the end of what it found and last 3 are constant memory codes found. Like I said car starts and runs fine, I can run out and cruise for awhile then I’ll get to a random light, sit in neutral idling and I can just tell it’s gonna happen. It will idle funny, kinda fluctuate, I’ll here this loud whistle sound and it will turn off, unless I rev it and get moving again then it runs and drives and at this point I try and time lights so I make it through them and get back home. Could it be a heat soak issue with the tfi? I’ve seen more ppl doing these tfi relocation kits.
99AD615D-C3A9-4762-8732-C9A7DD2BFAFE.jpeg
685775FC-4FF3-4E97-9024-3BE7845ABDBE.jpeg
37CB72BF-2E15-43A8-A26A-2E25C7284AFE.jpeg

EB86192A-072C-4A9B-9054-E44EECB4B4A3.jpeg
E605A88A-6F69-41E2-BD0F-3F25EF75AE1D.jpeg
The hose is for your windshield washer bottle that is inside the drivers fender. The yellowish connector connects to a second hose which runs up to the squirter that squirts the fluid to your windshield.

The electrical plug in the last picture is for the EGR which you've removed and blocked off so tuck that away out of sight.

And like others have said that black vacuum line to the plastic pvc valve has to be in the lower intake... so I would use a little rtv to keep it in place.

I'm not sold on the issue being a vacuum leak though.. If it were a vacuum leak it wouldn't just pop up once in a while it would be constant.

If you had a tune done I wonder why your car has to idle at 1000 rpms... it should be a few hundred less
 
Thread starter Similar threads Forum Replies Date
LarsD Lx Left Me Stranded Again Fox 5.0 Mustang Tech 44
O Engine 89 Lx Died And Left Me Stranded Today Fox 5.0 Mustang Tech 8
U2SLO450 my car left me stranded Fox 5.0 Mustang Tech 5
Adam95GT Car Left Me Stranded... UGH! HELP!!! 1994 - 1995 Specific Tech 98
PoopDawg Car left me stranded for the first time ever today... 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 5
C my mechanic Swapped a 99 5.0 explorer 302 into my 94 5.0 left a much of stuff disconnected and abandoned it HELP!!! 1994 - 1995 Specific Tech 15
G Odd shaking on left upper side 1996 - 2004 SN95 Mustang -General/Talk- 4
M My Dad left me a yellow 67 rust bucket :) The Welcome Wagon 1
2 Brakes Right front and left rear brakes locked up. Classic Mustang Specific Tech 6
M Why is my left turn-signal light always lit?!! Fox 5.0 Mustang Tech 8
M Does anyone know what the hole to the left of the oil pressure sender is for?? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 6
Dustin2v Electrical 2001 GT - Left Sequential Taillight not working SN95 4.6L Mustang Tech 1
S Left blinker stays on with running lights. SN95 4.6L Mustang Tech 11
B 2004 Squeaking and Squealing when I turn wheel left or right The Welcome Wagon 1
B Sticker inside left door jamb SN95 4.6L Mustang Tech 1
R Noise coming from rear left wheel. Getting mixed information from facebook 1996 - 2004 SN95 Mustang -General/Talk- 1
67coupe Progress Thread 67coupe’s 89 LX - One paint session left!!! 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 301
C 1966 left front brake locks up when I radio the brakes Classic Mustang Specific Tech 3
The Shemdogg No left turn power steering 1965 - 1973 Classic Mustangs -General/Talk- 4
B sticking left front brake 1996 - 2004 SN95 Mustang -General/Talk- 9
true01blueGT 2003 mustang gt only left driver tweeter 1996 - 2004 SN95 Mustang -General/Talk- 1
F Humming In The Front Left Of Car 2005 - 2014 Specific V6 Tech 0
G Expired 1970 Mustang Front Left Clip $250 Interior Exterior Parts 0
J Wheel/tire Shakes Bad When Turning Left At Hwy Speed Please Help! 2005 - 2014 S-197 Mustang -General/Talk- 5
Slo5Oh89 Front Left Sagging Fox 5.0 Mustang Tech 6
TheFleshRocket Help! Attempting To Troubleshoot Mach 460 Front Left Tweeter Not Working. Mustang Sound & Shine All 1
9 Aunt Passed And Left Me Her Mustang... What To Do 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 47
teebluestang Fuel Gauge, Speed O, And Left Turn Signal Fox 5.0 Mustang Tech 1
dr. Dan W. Greetings From Way Out In Left Field! The Welcome Wagon 4
MCF84 Expired 2015/2016 Mustang Left Side Hood Vent Interior Exterior Parts 1
Jordan Warta 1995 5.0 Making Creaking Noise With Hard Left Turns? 1994 - 1995 Specific Tech 0
Joshuaachury Brakes Pulling Left When Braking And Random Scrapping Noise When Turning! SN95 V6 Mustang Tech 1
stykthyn Left Bank Exhaust Cold Fox 5.0 Mustang Tech 5
J Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 5.0 5 Speed Gt 1994 - 1995 Specific Tech 5
J Newbie Here. Dont Know If I Have Enough Hair Left To Pull Out. Need Help With My 95 Gt The Welcome Wagon 0
mpcv2000 Electrical Doing A "wire Tuck" On A 93 Lx. Left Frame Rail Side Harness Blk/wht 2 Into 1 Goes Where ? Fox 5.0 Mustang Tech 5
skiwesser11 Dumb Q: Would I Know If Pilot Bearing Was Left Out? Fox 5.0 Mustang Tech 8
C Expired 94-98 Left Rear Brake Caliper - A1 Cardone - Never Installed Wheels Tires Brakes 0
HexMora Rear Right Tire Sticks Out More Than Rear Left Tire. Fox 5.0 Mustang Tech 5
7 88 Gt No Brake Lights/ No Left Rear Turn Signal 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 3
M How Do I Be Left Alone In My 73 Mustang? 1965 - 1973 Classic Mustangs -General/Talk- 19
65Rob Left And Right Control Arms? Classic Mustang Specific Tech 2
M Mach 460 Left Side Not Working 1996 - 2004 SN95 Mustang -General/Talk- 5
Toolmaan 88 Mustang Rust On Frame Rail Below Left Shock Tower Fox 5.0 Mustang Tech 2
Busamike 1965 Fastback 347 Stroker, Whit Smoke Out Of Left Exhaust? Classic Mustang Specific Tech 3
B Help Build A 302 For A Sand Rail Using Left Over Parts... 1965 - 1973 Classic Mustangs -General/Talk- 6
GoldenEagle91 Suspension Clunk When Turning Left Fox 5.0 Mustang Tech 8
MRaburn 2015 Ford Mustang Convertible Enters Stage Left StangNet Site News 0
90lxwhite Any E7 Guys Left Out There? 1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk- 37
J Expired 89 Gt Left Door Complete Power No Rust Interior Exterior Parts 0
Similar threads