Losing my mind with electrical issues.

  • Sponsors(?)


Mar 26, 2022
14
5
13
32
Kentucky
One thing you said stuck out, bad motor mount.I
This is easy to check, have someone let the clutch out in gear while you observe . If the motor lifts up maybe just maybe it's pulling on some wires.
In reverse it would 'nt pull the same direction so check it out.
Seemed fine, didnt have anymore movement than any other V8 when you rev it or drive forward.
 

manicmechanic007

Mustang Master
Sep 26, 2017
1,536
437
93
62
A wiggle test is in order for the cluster connectors
Just the cluster glitching out?
 
  • Like
Reactions: 1 user

manicmechanic007

Mustang Master
Sep 26, 2017
1,536
437
93
62
You got wires that dump the cruise on the brake pedal and clutch
Check those harnesses real close and the switches for obvious problems
A good scan tool can see when either of those pedals are depressed? Maybe?
I think my NGS would scratch it
 
  • Like
Reactions: 1 user

manicmechanic007

Mustang Master
Sep 26, 2017
1,536
437
93
62
You got one or two grounds above the drivers feet
You got one or two in behind the left kick panel
A Ford EVTM for your car would be a good investment (shows every ground location and has pics)(all the schematics) etc.
I only have one mustang evtm a 1989 I think or I would post pics for you
 
  • Like
Reactions: 1 user

weendoggy

Active Member
Jan 14, 2019
102
36
38
69
Aptos, CA
Cables seem to be fine, cleaned a large majority of the grounds as well. Replaced both cable ends as well. Its something piddly.

.
Cables?? The 2002 uses an electronic speedometer with OSS that is run through the PCM. I tried something yesterday on my '02 but didn't do what I thought. Was thinking the fob battery was your issue so I took mine out hoping it would replicate your issue, but it didn't. Still trying to wrap my brain around this.
 
Mar 26, 2022
14
5
13
32
Kentucky
Cables?? The 2002 uses an electronic speedometer with OSS that is run through the PCM. I tried something yesterday on my '02 but didn't do what I thought. Was thinking the fob battery was your issue so I took mine out hoping it would replicate your issue, but it didn't. Still trying to wrap my brain around this.
We were referencing the battery cables.
 
Mar 26, 2022
14
5
13
32
Kentucky
I fixed it. It ended up being the one thing I overlooked. The ground running from the core support to the battery was completely gone. All this fuss over 3 inches of wire......
 
  • Like
Reactions: 3 users