NEED HELP: Belt Slip w/ AC on Newly Vortech S/C 4.6L

alwayshi

Member
Feb 22, 2019
43
7
18
28
Hawaii
Hello everyone,
I've recently supercharged my 2000 GT with a vortech V3 heritage supercharger.
I'm currently in the process of datalogging and tuning - the one problem that I've encountered is belt slip/squeal as soon as I turn the a/c on. The a/c worked flawlessly before the charger went on. I'm almost 100% certain my pulley alignments are good, (since it only squeals with the a/c on as well). It's the belt that vortech supplied (108.2"), and with the stock 3.6" pulley supplied as well.
I've changed the tensioner today and it still seems like the belt has too much slack. Maybe I was sent the wrong length belt from Vortech?

Any ideas are greatly appreciated!
 

Attachments

Last edited:
  • Sponsors(?)


Sluggie24

Active Member
Apr 8, 2017
119
18
28
45
Did you replace the tensioner with a stock replacement or a stronger one? If the belt seems too loose then maybe try a shorter one.
 
  • Like
Reactions: alwayshi

alwayshi

Member
Feb 22, 2019
43
7
18
28
Hawaii
Did you replace the tensioner with a stock replacement or a stronger one? If the belt seems too loose then maybe try a shorter one.
Correct, replaced it with a stock replacement from Gates.
I ordered a shorter one and should be ready to pick up tomorrow so I’ll report back then. It’s so crappy having to remove the charger just to change the belt
 

alwayshi

Member
Feb 22, 2019
43
7
18
28
Hawaii
@Sluggie24 rep to you buddy.

So the belt came in from the other side of Hawaii island later this afternoon. Upon receiving it, I noticed on the packaging, it stated the OC was 108 1/8", but not to worry, upon further research that's not the working length (which in actuality is 107.55").

Attached is the Gates belt # and picture of a 14" pipe wrench, with a hose cut and taped to the jaw that I use to release the tensioner (works like a charm and I got the idea from youtube). A/C compressor turns on and its nice and silent (hooray!). Funny how the vortech supplied 108.2" belt was too loose for stock pullies, and even the stock 3.6" supercharger pulley. Anywho, I'll be ordering a spare belt to always keep handy.

Thanks again Sluggie!
 

Attachments