Need to adjust Idle on FRPP 70mm T/B!!! (ASAP)

Discussion in 'SN95 4.6L Mustang Tech' started by BlackenedSVT, Mar 11, 2006.

  1. Just installed my ported plenum and 70mm FRPP Throttle body. I was using the BBK T/B install page as a guide, but now i ran into a problem. There is no "idler screw" on my FRPP T/B Like there is on the BBK one. So my idle is at 1,500 RPM right now on my car, and if i blip the gas it shoots to like 4,000 RPM and hangs there for a few seconds before it drops back down to 1500 again. I've let the car run for 10min and the computer never reset the idle, so i need to find an adjustment screw.

    Can anyone help me out? Can't really drive home from my shop until i fix this. LOL

  2. CHECK ENGINE LIGHT JUST CAME ON.... (after 5min idleing)

    Throwing a P1506 Code (specifying to check for vacuum leaks)...doing so now. Also checking that EGR gasket i put on, im thinking that is the problem since it is thicker than the stock one...Its just an EGR gasket my friend gave me with the T/B so i put it on. I'm going to check it out, im thinkgin maybe thats throwing the code...

    Any help?
  3. Found that the line running from the stock "CAI" (intake tube) to the driver side valve cover was disconnected. I reconnected it and restarted the car.

    Still high idle.

    I disconnected the battery now and am letting the computer re-set and am going to see what happens next.

    Still waiting on someone to chime in with an idle adjustment suggestion


    Ok car started up again after reconnecting the battery. Idle bounced from 1200-1500 for a few seconds, and ist sitll having a high idle problem at 1500and hangs after reving. ENGINE LIGHT IS OFF at the moment. I will drive it home now and report more later...
  4. Your car does not have an adjustable idle. I know that sounds retarded but it is right out of the Haynes manual. There is no adjustment screw, its all computer baybee :D

    Anyway, have you messed with the TPS? It is difficult to get it adjusted just right. There are tons of threads on adjusting TPS. When you tighten up the screws on the TPS that hold it in place it can move enough from the screw tightening to throw it off. It is very very touchy. Use a multimeter to get it just right with key on and engine off. I do not have the voltage value memorized, do a search for that.

    Also, many report that when installing new TB it takes several days for the car to relearn fuel trims properly for the non-stock TB.

    You have reset the battery that is good. Now check the voltage on your TPS and follow the owner's manual instructions for relearning fuel trims after computer reset (battery disconnect).
  5. the black TPS with the two gold screws top and bottom? No i haven't adjusted that, although i did try messing with it once i'll try again. And i'll have to look up some more threads on TPS adjustment.

    I just got back home and the car did NOT throw an engine light/code. So its all good. Except the high idle of course. It was definately interesting to drive...backing out of the shop the car wouldn't go in reverse, and then it grinded reverse and sent my speedo gauge from 0-40mph then back down to 0 again....quite interesting. then on the drive home the car was constatnly pulling because of the high idle, it was like i was always givving it gas. Car basically drove itself through some gears lol

    But im home now...going to look into this TPS adjustment...
  6. Also, check out how to re-learn fuel trims after PCM reset.

    And many report high idle for several days after TB upgrade that eventualy evens out.

    If your new TB came with preinstalled TPS it is prob ok. If you had to swap your TPS over may have a problem.
  7. well its an aftermarket T/B so it has its own little black dial adjuster (not sure if THAT is the TPS or the black plug running from the wiring harness is the TPS). But if its the adjuster on the throttlebody u mean, then yeah the aftermarket one had its own.
  8. ok, just drove the car for some gas and the engine light came on again :(
  9. morning bump if anyone can help
  10. What codes are you getting?
  11. Well now that im home, i dont have the snap-on scanner anymore. But when I was at work yesterday it was throwing a: P1506 code, which is for a vacuum leak somehwere around the intake. (read my 2nd post).

    But my work is closed today so i can't scan it again, but i'd imagine the code is the same. I'm trying to look up the tech pages on the voltage readings and how to adjust the TPS. I do have my Fluke DVOM here at my house so i'll take it outside in a bit and try and frig with the TPS, just need to find out what im friggin with
  12. It seems to be a pretty common problem with any TB upgrade, but more common with the Accufab pieces for some reason. 90% of the problem is the computer just needs to relearn the idle. Most of the situations Ive encountered are as follows. Everyone does the install according to directions, no problems whatsoever. Start the car up and the revs jump and hang anywhere from 1200-1600 if no higher. A few seconds later it will drop a few hundred or so rpms, and eventually after a couple of minutes level off. My bf's did this after the 75mm install with the plenum/tb combo. Everytime he started the car or reved it, it would hand around 1400, then drop to around 1000, then settle to 750-800 after a min or so. After a couple of days this got progressively better. It would only hang at 1000, then drop to normal. Finally it stopped hanging and acted normal after a 4-5 days of driving. An easy fix is unplug the battery, and reset the computer. Then drive it for 30-45 mins normaly driving, then do about 30-45mins on the hw with the ac/heat on. This puts the computer through its normaly paces and lets it learn the idle more quickly. Works for most people but not all. The main issue he had with the combo was after a week or so of driving the hanging idle went away, but my damn gas pedal started sticking. As soon as you let off the trottle, the pedal would take some major effor to go back down. Very annoying, but it to went away after a few months of hassle.
    my car had similar issues, but her idle would not drop. I did the 70mm combo. You would start the car, revs would jump and hang around 1800 rpm, and never drop. The fix was to install a smaller diameter tube inside the tube that runs from the iac to the main air intake tube (one that goes to the tb). Just simply shove a smaller hose into the iac hose, and it should fix any stuck high idle. There is also a washer fix Ive heard for this, but never tried it. Some people will install a washer in the iac hose. Its the same principle just different ways to do it. maybe it'll help :shrug:
  13. Thanks for the input, but im not going to wait 4-5 days to potentially fix itself out, plus i certainly wouldn't wait months for it to finally go back to normal. Thanks but i'd like to know the correct way to fix this. I'm hopin SVTTech can come chime in with some TPS adjusting help =)
  14. +1

    However, I agree with everything Stangsgrl said... Not sure what Mike can add but he is a Ford tech.
  15. umm, do you have the IAC valve installed correctly?
  16. Not pics on correct installation? I'm going to look over everything in like 30min outside and try to fix it again.

    ...maybe i installed the IAC gasket the wrong way? :shrug: Pretty damn sure i didn't. I had to re-use the stock gasket though...
  17. Stangrl kinda hit on this earlier but I had the same thing happen with my Accufab. People said just run it and the computer will learn. Never happened. The problem was in the picture. I had the #1 and #2 hoses swapped, stupid mistake but it was dark and I was in a hurry:D and that's the correct order in the picture.
    That kinda helped but still had the hanging idle. You look really cool sitting in traffic with the car at 1800RPM's. Everyone is like, "yeah your a real bada** dude" So to fix that I used the copper cap mod. Big thread on it somewhere. But stick a 10 cent copper cap in line #2 with a hole drilled in the middle. Runs perfect now. The smaller the hole the faster the idle will drop between shifts.
    Try it before you take it into a shop. It's a possible cheap fix.:nice:

    Attached Files:

  18. Yeah i believe thats in the "How to fix slow dropping and haning RPM thread" ( for the Mach 1 guys. Are you saying thats the only way to fix this with an aftermarket plenum and t/b? :scratch: i find that hard to believe. got any more pics of the copper piece? They look like thay are two different things....where did u get that from?
  19. i dont know if this will help at all, but this is a write-up I did while istalling mine. For the first few starts everything went fine, then about 2 days after I did the install I started having a slightly erratic idle. After about 1 month, its working just fine. Maybe something in this thread will give you an idea of what you may have done differently. :shrug: I dont know, but its worth a look. good luck.
  20. see my problem was i slapped off the TPS, installed the new plenum and TB and slapped back on teh TPS. And it hink thats my main problem. That or the IAC.

    I was just outside examining the car, here is what i just found:

    1) with the car running, i disconnected the rubber hose going to the IAC, the car puttered down like it was going to die, but it didn' stayed on.... What does that mean? (i know this was a test someone told me to do)

    2) With the engine running i disconnceted the TPS screws slowly...once they were a tiny bit loose, i wiggled the TPS and the RPMS started shooting i dont know how to adjust it correctly, but im guessing this is my idling problem right here...

    Can some one help me out now that i've gone into detail more???

    Here are some pics...see if you find anything wrong...

    Picture of the ported intake:

    See anything wrong?
    View attachment 484000


    My trusty DVOM (my only real diagnostic tool at my house):
    View attachment 484004

    Now i was reading in the BullitArchives online that there are wires going to the TPS that i can set my DVOM leads to and then check the voltage reading going in, and then loosen and wiggle the TPS accordingly to get it between .97-.99 volts. What wires do they want me to check here? And how would i go about checking them?

    View attachment 484006

    Ok here is another picture. In this picture below the Red Cirlcle indicates the 3 wires going into the TPS, im not sure of their colors because i wasn't paying attention and its hard to see from this picture. I read on a web page that 1 wire shoudl be a 5v Ref Source, another should be ground, and the 3rd being the throtlle voltage between .93-.99 (closed) and 4.25 or 5volts (WOT).

    The Yellow Circle relates to Helty's write up on his T/B install, i believe he thought that THOSE 2 red wires were the throttle voltage. I'm pretty sure that is wrong though and the red circle i made over the TPS are the wires i want to use to check the TPS throttle voltage.

    Here is the picture:

    View attachment 484008

    Now...from all i've read about this...all i have to do is find the throttle voltage wire from those 3 wires going into the TPS, and then with the KEY IN, ENGINE OFF loosen the TPS enough so i can wiggle the TPS and get it to read .99v and then tighten it back up??? Is that correct?

    Attached Files: