New Chick with a Stang

Jun 27, 2018
6
0
1
40
San Antonio
Hey y'all, long time member/stalker, here on the west side of San Antonio (just outside Lackland) first time poster....I started with an '04 anniversary v6 with the pony package, but sucked water up the intake.
I was lucky enough to pick up an 01 convertible for $500! Of course, it wasn't in the best condition. The kid I got it from had it as a project with his dad, yet neither were mechanically inclined. It limped home and has been an ongoing work in progress.
To date, I've changed:
the top (picked up a replacement for $100!),
the engine bay wiring harness,
the headlights for the halos from the '04,
the AC compressor,
the fuel rail,
the upper and lower intakes with gaskets,
both heads and head gaskets,
a piston,
the throttle body,
the O2 sensors,
the exhaust manifold,
the egr, pcv,
the ignition coil, wires, and plugs,
the cylinder head temperature sensor,
and put in a cold air intake.
Because of the new top being black where the original was tan, I've also changed up the interior. Including:
the visors,
the seatbelts,
door panels,
carpet (which I dyed myself),
front kick panels,
door trim,
center console,
and the dash.
These are all black or grey now. The available parts cars were not verts, so I painted the front column trim on both sides as well as the back seat quarter panels the steering wheel and the front and rear seats. Other than the seats, these are all black or grey as well. With the seats, I had to go straight up white.
Now, that said, I've got a problem with my dash wiring harness. If anyone has actual photos of the connections on an 01 base 3.8 very, you'd be my freaking hero.
The issues:
1) instrument cluster does not illuminate when headlights are on;
2) both turn signal indicators in the gauge cluster flash fast like a bulb is out, but all bulbs are good;
3) even though blinker bulbs are all good, front passenger side will not come on (tested bulb by switching with driver's side);
4) radio comes on, but there is no sound emitted from speakers;
5) airbag light will not go off;
6) engine surges rythmiclly when ac is on and ac compressor does a continuous start/stop (this one's been ongoing from purchase).
When I replaced the dash, I switched the entire thing rather than mess with too much wiring, but had to add a couple connections and switch a couple pigtails. I've clean up the original harness and am going to put it back on, but the problem (and why I tried doing it differently) is that some of the wires came loose from the pinned connectors, hence my request for images.
And there's a random connector just dangling in the driver's foot well (barely off the firewall connection).
Sorry for such a long first post, (I'll also toss the question into the tech forum). Any help would be appreciated!
 
  • Sponsors(?)


kiddiccarus

The first widely accepted Tranny
15 Year Member
Dec 24, 2003
1,589
964
143
30 Mins from a Ragged GT
www.angelfire.com
WHOA?!?!?!?! Pictures!!!!!

I changed my tan top to black also.

* The Air Bag light may be a recall thing. Mine did the same thing but now will go off after 10 minutes. (I never went to do the recall)
* The blinking issue may be the turn signal selector switch. I found out mine was bad when my brake light would not come on, If I used the left signal the cruise would go off and my blinkers went rapid with no bulbs being out.
 
Last edited:
Jun 27, 2018
6
0
1
40
San Antonio
WHOA?!?!?!?! Pictures!!!!!
I'll have to get some once I put the dash back in, it's a mess right now!

I changed my tan top to black also.
Nice

* The Air Bag light may be a recall thing. Mine did the same thing but now will go off after 10 minutes. (I never went to do the recall)
The light doesn't stop, just constant, erratic, mind numbing, distracting flashing. And it's only don't it since changing the dash and harness.

* The blinking issue may be the turn signal selector switch. I found out mine was bad when my brake light would not come on, If I used the left signal the cruise would go off and my blinkers went rapid with no bulbs being out.
The weird thing is the front passenger blinker won't come on, but if I switch the bulbds, it makes no difference, the driver's side will flash quickly, the passenger side does nada, and again, this is only since changing the dash and harness.
 

kiddiccarus

The first widely accepted Tranny
15 Year Member
Dec 24, 2003
1,589
964
143
30 Mins from a Ragged GT
www.angelfire.com
You might need to pull that harness back out and use a multimeter to check continuity on each of the wires. If that is the change that is making this happen, one of the wires may have a break in them. Its a pain in the rear, but wiring is the simple answer and least in cost when you have to make a splice to correct it.
 

LILCBRA

I wish I didn't have all of these balls in the air
10 Year Member
Dec 6, 2005
2,491
1,479
164
48
Marietta, Ga
Welcome to Stangnet!

As for the AC problem, as I understand it they will short cycle when low on refrigerant if there are no other problems.