New Owner Many Issues. Help!!!!

Ms coco

New Member
Mar 10, 2016
3
0
1
31
Hello so I have a 2001 mustang GT 4.6 most stock from what I know. Flow master exhaust new alternator and battery recently changed. Just did coolant flush earlier today. I bought this car from craigslist from a so called mechanic. The first day I had the at the car ended up dying that night. Battery was constantly being drained and took it to electric shop found out it was the defrost. I removed the fuse from the distributor box under the hood and the battery drainage stopped but now the battery light stays on. It has died a few times since then but I have no clue what is going on. I was told to check the ground from the battery but I'm not car savvy.
My next issue is a loud whining noise which I believe is a vacuum leak. I changed a couple of the hoses today but th noise is still going on and is coming from where the intake air filter is.
Last issue which I am most concerned about is my clutch and acceleration. A few days ago my car grinded a bit on the freeway going about 60-65 and I was downshifting from traffic slowing down. Now a couple days later my acceleration doesn't pick up how it should and the car sounds as if it's stalling a bit at take off. When driving slowly it will drive fine buy any harder acceleration the car barely moves amd takes a while to catch the gears. I really do not know what to do and don't want to spend a lot of money from a
Mechanic that will take advantage of me like I had done before. I will post video and pics as well so you can see what I am talking about.
 

Attachments

  • Sponsors(?)


Ms coco

New Member
Mar 10, 2016
3
0
1
31
PS I have a video of the noises am the idling issue from the vacuum leak. This site is not letting me post it tho.