Only one reverse light?

Sycostang67

Member
Sep 27, 2019
34
23
16
41
Kuna, ID
So I noticed my driver side reverse light was out. I got some LED bulbs to replace them both. When I removed the bad bulb, I noticed it looked fine, filament intact, no signs of blackening. I swapped out both bulbs and the driver side still doesn't work. I did try reversing the bulb, still no luck, tried the other known good bulb and still nothing. The passenger side is working just fine with the LED. I hooked up my scan tool and I get a code, B2525-20 Left rear backup lamp, circuit failure. I tried googling and get nothing, I see no fuses that work these lights either. What gives?
 
  • Sponsors(?)


7991LXnSHO

Now I want a 10 year badge
10 Year Member
Sep 1, 2010
4,118
1,076
184
Kearney, NE
Since no one in your year is offering specific help, I can offer general trouble shooting.
It’s helpful the computer is telling you the general issue.
Check at the socket for power and ground. 11-15 years is long enough that a ground could be corroded. If the ground is good and the socket is good, you are likely going to be tracing the power wire back to where there is power and fixing a bad connection or wire.
 
  • Agree
Reactions: MustangIIMatt

Sycostang67

Member
Sep 27, 2019
34
23
16
41
Kuna, ID
I did check the socket and truck wiring when I swapped bulbs, but it was getting late and didn't have time to investigate further. I will be installing a dash cam soon so I will use that opportunity to dig deeper with some panels removed.