Power Seat Problem Puzzle

Discussion in '1979 - 1995 (Fox, SN95.0, & 2.3L) -General/Talk-' started by joetrainer31, Jul 23, 2013.

  1. Hello brainiacs,

    As is common with the 94/98 Mustangs w/power seats I am experiencing power seat problems. However, I am a bit puzzled by the problem. I simply have no power going to the seat. Here is what I know through testing thus far:

    1) All fuses under hood are fine.
    2) All fuses under dash are fine.
    3) Both power motors & seat switch are fine (connected jumpers straight from battery to seat connector).
    4) Wire from under carpet shows no power.
    5) Connector on wire from under carpet shows no power.

    Please advise.
  2. I know this is worthless and not helping you one ioda but my power seat in the 95 will go up and down but won't go forward or back with out pushing the button and pulling forward on the steering wheel moving the seat manually
  3. Yours has chewed up the gears that move the seat forward. An aftermarket company sells a fix it kit for 100 bucks. OR grab one from a salvage yard like I did for 25.
  4. Somewhere in the wires there is a fault. Nothing to do but start backprobing till you find that spot and fix it.
  5. Thanks man. So just get a new seat motor?
  6. Doesn't sound like a motor issue. Rather an open circuit to the seat motor and/or worn drive gears.
  7. No. Replace the whole power seat track. Its a total of eight bolts to remove and then reinstall.
    joetrainer31 likes this.
  8. Yes, just replace the entire rack AFTER you have verified that it is not the switch. Try hooking up leads direct from your battery to the seat, attempt to operate up/dwn fwd/bck, and observe what is going on.

    Thanks for all the input guys. I'm simply going to run a new wire from the fuse box to the seat. I don't want to cut into the tapped up harness underneath the carpet, thus I'll just secure a new wire to it.
  9. You can test that motor with a cordless drill battery it pulls hardly any juice
  10. Nice idea. Never thought of that.
  11. Guy at the junkyard showed me that
  12. Guys at junkyards have many ideas. I think its due to lack of facilities and amenities (i.e., they improvise).
  13. I had the same problem but my seat motor was fine. Over time the lithium grease on the screws thickens up and the motor isn't strong enough to move the seat. I would clean off as much grease on the screws as you can (a little left is OK), then re-grease the screws with white lithium grease. This may get your seat moving again.

    If the seat moves very slowly after re-greasing the screws, then your motor is shot. You can replace the motor but I always found it to be a PITA.
  14. Ok, so after confirming that there was a good ground for the pwr seat wire I followed the lead wire all the way back to the firewall and observed that it was dead until there. My choices at that point were to remove the fuse box under the dash and cut the wire bundle open to access the correct wire and replace it (HARD). OR, run a new wire from the positive battery terminal with an inline fuse and splice into the factory wiring under the carpet (EASIER). Which did I choose?
  15. Thanks will give it a try
  16. Good for you on doing the right thing! Cutting open the wire bundle was a good choice.

  17. I gotta admit to being a dummy. However, I also found an interesting issue.

    Im a dummy because when I tested the fuse I only tested one side of it so it appeared fine. In reality I had only tested the blown side. Therefore, the wire had no power all the way up to the fuse box...duh!

    Secondly, once I replaced the fuse the seat worked like new...UNTIL bolted it back in place. Once bolted in place the seat started acting sluggish and eventually died. Thus, I began unbolting it and messing with the pwr lever in order to reach the bolts. I found that after I listened the bolts a little, that the seat started working fine again.

    I experimented with loosening and tightening while activating the controls and observed that if I tightened the bolts too gorilla tight that the seat would fail to operate, but if I loosened them a bit, it would work fine. My guess is that if the seat bolts are too tight that it may cause the seat track to bow or distort somewhere under the seat. I further surmise that the distortion of the seat track puts too much strain on the motors, they pull too much amperage, then they either blow the fuse, or repeated over time they burn themselves out. Either way loosening the bolts just a bit solved the entire problem once the fuse was replaced.

    Thank you for all your input gentlemen.
  18. You should be able to tighten the bolts down tight without the seat track getting torqued that way. Is it possible you have the seat track on backwards? If I remember right, the motor should be towards the back of the seat, not the front.
  19. I agree about being able to tighten w/o an issue, but nonetheless the issue was corrected by backing off the bolt torque just a bit.

    I never thought of the backwards issue. Good thinking. However, the motor is towards the rear of the seat, if I remember correctly.

    Again, I'm only making an educated guess about the seat's issue because I cannot actually see what is going on with the track. All I am sure about is that loosening helped solve the problem. Its the "why" of the problem solving Im having to theorize about. Any further thoughts?
  20. Nope, all tapped out here.