Radiator Fan And Wiring Mess

Red betty

New Member
Aug 14, 2017
3
0
1
21
I bought a 95 gts to fix up and is currently a mess. The fan works when connected directly to the battery but I don't think it's turning on when it gets up to temp. On the dash the temp gauge looks higher then it is and rev gauge doesn't work at all. The guy I bought the car from was trying to fix it when he gave up and sold it. The wiring in the engine looks bad and probably needs to be redone. I don't know a lot about cars and any advise is appreciated.
 
  • Sponsors(?)


revhead347

Apparently my ex-husband made that mistake.
15 Year Member
Jun 14, 2004
8,935
1,535
214
41
Acworth, GA
Can we have some wide angle pictures of the general cluster:leghump: we are dealing with here? These cars are old, and we actually deal with quite a bit of old hack jobs on this forum.

Kurt
 
  • Like
Reactions: 1 user

Red betty

New Member
Aug 14, 2017
3
0
1
21
Doesn't look terrible
 

Attachments

  • 20170815_081555.jpg
    20170815_081555.jpg
    795.5 KB · Views: 213

jozsefsz

5 Year Member
Aug 11, 2013
1,227
341
114
50
Cleveland OH Area
Run the KOEO self-test which will run the fans (installing the proper scanner with the key on, engine off will cause that test to begin). This ensures most of the circuitry is working (including the CCRM), if not you can troubleshoot from there. This eliminates the temperature sensor and its wiring from the equation.
 

revhead347

Apparently my ex-husband made that mistake.
15 Year Member
Jun 14, 2004
8,935
1,535
214
41
Acworth, GA
Mother of God. Be glad it runs at all.

Pull the codes first and see what that brings up. Very likely one of the relays in the CCRM. Where's HISSIN?

Kurt
 
  • Like
Reactions: 1 user