Radiator Fan And Wiring Mess

Red betty

New Member
Aug 14, 2017
3
0
1
19
I bought a 95 gts to fix up and is currently a mess. The fan works when connected directly to the battery but I don't think it's turning on when it gets up to temp. On the dash the temp gauge looks higher then it is and rev gauge doesn't work at all. The guy I bought the car from was trying to fix it when he gave up and sold it. The wiring in the engine looks bad and probably needs to be redone. I don't know a lot about cars and any advise is appreciated.
 
  • Sponsors(?)


revhead347

I have face herpes.
15 Year Member
Jun 14, 2004
7,487
678
204
39
Acworth, GA
Can we have some wide angle pictures of the general cluster:leghump: we are dealing with here? These cars are old, and we actually deal with quite a bit of old hack jobs on this forum.

Kurt
 
  • Like
Reactions: imp

jozsefsz

5 Year Member
Aug 11, 2013
1,112
254
114
48
Cleveland OH Area
Run the KOEO self-test which will run the fans (installing the proper scanner with the key on, engine off will cause that test to begin). This ensures most of the circuitry is working (including the CCRM), if not you can troubleshoot from there. This eliminates the temperature sensor and its wiring from the equation.
 

revhead347

I have face herpes.
15 Year Member
Jun 14, 2004
7,487
678
204
39
Acworth, GA
Mother of God. Be glad it runs at all.

Pull the codes first and see what that brings up. Very likely one of the relays in the CCRM. Where's HISSIN?

Kurt
 
  • Like
Reactions: ursixx