Radio install

94chirps

New Member
Jun 25, 2018
21
0
1
Hello all I have a 2003 GT with the Mach 460 I just put a double din radio in it had and aftermarket radio that work great, but I went double din, now when the volume reaches about half the front speakers cut out, any ideas would be appreciated this is driving me crazy please help, also the to RCA's that come from the factory amp, where would you plug those in
 

Attachments

  • Screenshot_20200429-222811_Gallery.jpg
    Screenshot_20200429-222811_Gallery.jpg
    314 KB · Views: 85
  • Sponsors (?)


Canadianfox

Member
Aug 18, 2019
27
1
13
Hello all I have a 2003 GT with the Mach 460 I just put a double din radio in it had and aftermarket radio that work great, but I went double din, now when the volume reaches about half the front speakers cut out, any ideas would be appreciated this is driving me crazy please help, also the to RCA's that come from the factory amp, where would you plug those in
Do you have I link box attached to keep any steering wheel controls or no? If you do then the volume out to amp is turned too low and that’s why your speakers cut out.If not check your audio config including sub amp out and post back .The rca câbles go from your radio to your amp(s) depending on your setup .I usually run one amp for my speakers and one amp just my sub unit with an appropriate radio with those outputs .Obviously your speakers are then wired into your amp(s) .If you don’t have a speaker amp then they are wired into your radio .Not sure if your mustang had factory amp(s) you might wanna check that
 

94chirps

New Member
Jun 25, 2018
21
0
1
Do you have I link box attached to keep any steering wheel controls or no? If you do then the volume out to amp is turned too low and that’s why your speakers cut out.If not check your audio config including sub amp out and post back .The rca câbles go from your radio to your amp(s) depending on your setup .I usually run one amp for my speakers and one amp just my sub unit with an appropriate radio with those outputs .Obviously your speakers are then wired into your amp(s) .If you don’t have a speaker amp then they are wired into your radio .Not sure if your mustang had factory amp(s) you might wanna check that
Thanks for the reply I have the Mach 460 and I have the harness from the factory amp to 2 RCA wires, but my radio only has one subwoofer output, not sure where to plug them in cuz with any base at half volume the front speakers cut-out I turn the volume down a couple notches and they come right back on