Progress Thread SN95 "Project Father & Son" 1994 GT

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
Nice parts hoard you have going there.
Fwiw you can buy the compressor cube at any any autozone/advanced etc for like $10 bucks
10A06214-4C3C-4404-A0E1-1AA105AC251B.jpeg
That's the garbo tool I have from that HELP rack. None of the notches line up with the rear caliper piston. I need 2 notches that are longer.

I have a welder, I'm about to make one specific to all my cars so I never have to use these tools again.
 
  • Like
Reactions: General karthief
  • Sponsors(?)


VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
Episode 7 "Project SN95 Father & Son"

*Review all the items we installed
*Revealed the new car name
*Front end parts arrive
*Pick up parts at Steeda
*Run codes with scanner
*Parts to install next episode
*Bonus Scene - Shelby tries to catch her nemesis

View: https://www.youtube.com/watch?v=vTAs6VtyPHU&t=330s
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
In the next episode I hope to install the Adjustable Clutch Cable, Quadrant and Firewall.

It's the Steeda Firewall Adjuster, FRPP Quadrant and FRPP Cable.

I also got the OEM front suspension parts.
*Sway Bar Bushings - Prothane
*Sway Bar End Links
*Ball Joints - I am so not looking forward to this one. I'll need to rent the tool, ugh.
*Outer Tie Rods
*Inner Tie Rods - Not going to install them until needed.

Ran my code scanner, got 564 and 121. I knew the 121 was coming since the car had a weird idle plus it has some adjusting plate. I'll get to use that in the next episode as I try and dial in the correct voltage.

44278737422_aac88d834d_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

I'm having a charging issue. After putting a new battery in the day I got the car it started to start oddly. A few weeks later it didn't start at all. The battery wouldn't hold in the 12's. I took it back and they charged it to 13.34V (as you can see Episode 7). It's still in the high 11's and won't charge up into the high 12's. I'm gonna get a new battery to rule this out. I'm sure a new alternator is in order.

43609941034_693c22d9df_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Front end parts.

43609739084_80a1727a9d_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Shelby and I watching the Formula One race.

44278745882_862f3fa8c6_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
I've been doing little stuff with the Mustang. My son the last few weeks has been out of town so we haven't worked a ton on it.

It needs a new alternator now because it's draining the battery big time.
It needs rear calipers now, the right rear piston is stuck out. I can't get it to retract with the pressure or E-brake.

What I've been doing is working on the intake. Had to get the crap black paint off of it and of course my red paint was underneath (I painted the red back in 2002).

I have video of a few things for the next episode.

Removing the paint with stripper.
43783905394_5214d65eda_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

43606228425_8ce795233a_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

43797919664_9ab932da0f_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Still not done, just called it quits for the night.

30632089618_b08dbb915a_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

44451807492_f9176ab16d_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
Found a new issue with the intake, this time the lower. I've been working on the upper so much I never even looked at the bottom portion.

So the lower is not from Edelbrock, it's the Professional Products Made in China knockoff.

I put the new upper gasket on and noticed lots of metal showing. The ports were so small, they were uneven and not one was the same all the way down the line.

So I a straight line down in Sharpie to see if my eyes were playing tricks on me, nope all uneven. I then put the gasket on and started porting the chambers.

Here is the line. As you can see, all of them aren't the same shape.

44605151382_aacb6822c1_h.jpg
Untitled by Joe Pisciotta, on Flickr

Started shaping the chambers.

30784549118_cc382e5811_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

I still have more shaping to do.

43936342264_14087e9ec7_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Had to stop, my hands were vibrating so much I couldn't feel them. I'll continue tonight.

30784861028_c46e6dfa1e_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
"The Onion" has really been kicking my ass lately which is why Episode 8 hasn't been released.

I've been having charging issues since day 1 and last night I finally....finally had the break through I needed. The car was stuck at 12.0V, while running then wouldn't start again (it will be in the next episode). I changed the Alternator and it only brought me up to 12.4v but after idling the volts decline. Last night I decided to chase every ground on the car and I found the issue. A few grounds were cut and dead, I found chaffed ground wires under the battery tray that go to the power box. After I repaired everything the car is now making 14.7v while idling. That's a Victory! The voltage gauge in the car isn't sitting a tad past 8 anymore, it's far the right now.

30888847528_f1abec788c_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Then "The Onion" struck again! One thing this car is good at and that's idling. Well I heard a weird ticking on the passenger side and the idle is stumbling, wants to stall. I look down by the passenger header and I see some smoke, smells electrical. The plug wire is sitting on the header and put a hole in the boot. The ticking was the spark zapping the header through that hole. Placed an order to Steeda for 94-95 Specific plug wires, these were stock anyway which needed to go.

42949305190_31ed43de4b_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

43850082035_d1c4009b0b_h.jpg
Untitled by https://www.flickr.com/photos/[email protected]/, on Flickr

Got to do the following:
*Install the Steeda Plug Wires
*The Passenger Rear Caliper Piston is still stuck in the out position, I need to work on this.
*The Edelbrock Lower / Upper Intake ports needs to be fixed (see my last post above).
*Install the new OEM Tie Rods Inner / Out (I'm just going to do it all).
*Install the new Prothane Sway Bar Bushings.
*Install the new Strut Bar End Links.
*Not sure if I'll do the Ball Joints yet, I don't have the removal tool. I'll look into that.
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
It's going down now!

We found some bootlip stuff too. Example, just about every connector has one or both tabs broken off.

I also found some injector o-rings laying around. Hopefully all of these injectors do have the o-rings and there from the 19's. Don't know why the dude upgraded to 24 pound injectors.

We are also taking off all the smog equipment. We will weight it all to see what the total is.

43086749790_197dd1c720_h.jpg
Untitled by jpjr501, on Flickr

29975381927_002056ebc3_h.jpg
Untitled by jpjr501, on Flickr
 
Last edited:

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
More work went down last night.

More bootlip stuff found, ever connector tab is either broken or has none. People don't know how to remove a Ford connector or what?

Anyway, it's down to the block. Going to paint the fuel rails, they are rusty and dirty. Want to paint the valve covers too.

31045317088_ddf49d8822_h.jpg
Untitled by jpjr501, on Flickr

44198429264_000be99ffc_h.jpg
Untitled by jpjr501, on Flickr

44198430464_51f2855fb7_h.jpg
Untitled by jpjr501, on Flickr

44918065961_5e452eff31_h.jpg
Untitled by jpjr501, on Flickr
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
More work last night.

The dirty dingy valve covers were bothering me so I popped them and painted them bronze. Did the same with the fuel rail.

43134570360_f9f35167d3_h.jpg
Untitled by jpjr501, on Flickr

44226727594_2cc15245fd_h.jpg
Untitled by jpjr501, on Flickr

43134571980_2a3fdbeb79_h.jpg
Untitled by jpjr501, on Flickr

31074659918_42e143b47e_h.jpg
Untitled by jpjr501, on Flickr

44226730084_e616f5fd64_h.jpg
Untitled by jpjr501, on Flickr
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
Nice! Going for the 289 HiPo look?
Don't even know what that is. I assume they used a bronze color.

I just thought I'd mix it up instead of black, grey or silver. Although those color do hide the imperfections and this bronze brings them out clearly.

After I"m done and it doesn't look right I'll change it. For now I'm digging it.
 

02 281 GT

Agreed...My wife has great Boobs
10 Year Member
Feb 3, 2009
1,811
1,054
164
Wichita Falls, TX
Don't even know what that is. I assume they used a bronze color.

I just thought I'd mix it up instead of black, grey or silver. Although those color do hide the imperfections and this bronze brings them out clearly.

After I"m done and it doesn't look right I'll change it. For now I'm digging it.
It was technically gold, but the look is very much the same. I think it's a nice touch. This is a picture of a 1965 with a 260, but the 289 HiPo was dressed the same way.

HiPo.jpg
 

VibrantRedGT

"STANGNET'S PENGUIN SMACKER"
15 Year Member
Nov 29, 1999
14,633
396
144
48
Boca Raton, Florida
www.mustangworks.com
Didn't get much done but chasing threads on the used intake and ditched the heater stuff on the lower intake.

In order to get the temp sensor to work I need the adapter so I did the same mod as my previous 94.

I cut the heater tubes, capped off the upper one with the temp bung, stripped, primed it, painted it and installed it. Here are the pics.

30094899667_492133bbb3_h.jpg
Untitled by jpjr501, on Flickr

43219352600_9a2801e0bb_h.jpg
Untitled by jpjr501, on Flickr

44311348594_b55525094c_h.jpg
Untitled by jpjr501, on Flickr

30094898877_0c2b7675ec_h.jpg
Untitled by jpjr501, on Flickr