Steve's Megasquirt/tunerstudio Help Thread

  • Sponsors (?)

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
@bird_dog0347
Here you go the startup idle should be fixed now, i will need another datalog.
Thanks a ton! I'll have to try it out tomorrow evening as I have a wedding this afternoon, party this evening, and a shooting match tomorrow morning to go to. I'll throw that one on there and data log a cruise afterwards. Thanks again for helping with the startup, not sure I would have figured all those changes out on my own.
 
Feb 6, 2012
79
5
18
50
@[email protected]
I found time to adjust the tune file for you. Looks like we are making progress.
cold start idle oscillation likely from low rpm, this should fix it.
Its idling to high. I tried to bring it down with my idle control adjustment plate, but it only came down slightly. I am on the east coast also. Available most days around 9pm for a remote. Thanks
 

Attachments

a91what

I plan to eventually problem is time
Mod Dude
Apr 6, 2011
6,292
3,765
204
29
Hillsborough county
Its idling to high. I tried to bring it down with my idle control adjustment plate, but it only came down slightly. I am on the east coast also. Available most days around 9pm for a remote. Thanks
Sorry should have specified, that is on purpose now I should have the needed information to build the closed loop idle program.
 

a91what

I plan to eventually problem is time
Mod Dude
Apr 6, 2011
6,292
3,765
204
29
Hillsborough county
Car starts off with some surging at idle. RPM"s shoot up to almost 3000 RPM when tempts get up to 180*
Your car is insisting on being difficult... lol. Are you using a standard ford IAC motor on the car?
 

Attachments

a91what

I plan to eventually problem is time
Mod Dude
Apr 6, 2011
6,292
3,765
204
29
Hillsborough county
GGRRRR..... try this...... if this does not work i will have to do some archaic tuning methods in the control algorithm... lol..
what firmware are you currently running?
 

Attachments

Feb 6, 2012
79
5
18
50
GGRRRR..... try this...... if this does not work i will have to do some archaic tuning methods in the control algorithm... lol..
what firmware are you currently running?
Using v3.0.60.00. Wow! Better
 

Attachments

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
@bird_dog0347
Here you go the startup idle should be fixed now, i will need another datalog.

I didn't get time to go for a drive but I was able to get the tune loaded and let it idle with some revs for a bit. There's still some surging here and there but I'm not convinced it isn't hardware related as my stock throttle body sucks out loud and has a really sticky movement from full closed to any other position. Then there's the IAC, no idea how good it is. I'm already planning to get an Accufab 70mm in the next few weeks so I'll just get a new IAC while I'm at it just to eliminate that as a possibility.
 

Attachments

a91what

I plan to eventually problem is time
Mod Dude
Apr 6, 2011
6,292
3,765
204
29
Hillsborough county
I didn't get time to go for a drive but I was able to get the tune loaded and let it idle with some revs for a bit. There's still some surging here and there but I'm not convinced it isn't hardware related as my stock throttle body sucks out loud and has a really sticky movement from full closed to any other position. Then there's the IAC, no idea how good it is. I'm already planning to get an Accufab 70mm in the next few weeks so I'll just get a new IAC while I'm at it just to eliminate that as a possibility.
Hopefully this will take care of the really high warm up idle and the oscillation in the idle. If we can get this nailed down tight i can lower the idle speed some [i would like to get it down to 800 or so]...
Either way when you get some time take the car for a drive if it runs well enough to do so, the longer the datalog the better. If it runs well do some pulls in second gear, this will let me tune the fuel and has a lower load stress on the engine [more forgiving if its lean]... If it bucks or coughs lift.
I have the EGO correction set so that it can correct even at WOT so if the engine is lean it will add fuel, once the tuning is done i will change that setting so it does not correct at WOT.
 

Attachments

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Sounds good, I'll try to get out for a drive today... With the kids being home on spring break and me working from home I haven't had a lot of time this week.
 

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Ok, took it for a short drive. First thing I did was upload 1.2 tune and start it up... forgot to start logging for the first few seconds but then after a few seconds of running and logging it was getting a new popping noise in the exhaust so I killed it and put version 1.1 back on it. Started it up again and all was good, or at least same as the other day. I drove to the gas station, got a drink, then came back home. There are 3 logs attached with the shortest being the 1.2 tune for just a few seconds. Then 1.1 tune going to the store, and 1.1 coming home from with a few 2nd gear short pulls as I didn't want to attract too much attention just yet and wasn't in Mexico.
 

Attachments

a91what

I plan to eventually problem is time
Mod Dude
Apr 6, 2011
6,292
3,765
204
29
Hillsborough county
Ok, took it for a short drive. First thing I did was upload 1.2 tune and start it up... forgot to start logging for the first few seconds but then after a few seconds of running and logging it was getting a new popping noise in the exhaust so I killed it and put version 1.1 back on it. Started it up again and all was good, or at least same as the other day. I drove to the gas station, got a drink, then came back home. There are 3 logs attached with the shortest being the 1.2 tune for just a few seconds. Then 1.1 tune going to the store, and 1.1 coming home from with a few 2nd gear short pulls as I didn't want to attract too much attention just yet and wasn't in Mexico.
Only thing i can figure is it did not respond well to my attempt to richen the idle up. new revision for you.
 

Attachments