Steve's Megasquirt/tunerstudio Help Thread

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
So I got the new one loaded and data logged a startup idle to the driveway to wash it. I'm taking it out later to a get together and will data log that as well. The startup had some popping (backfiring, popping in exhaust) in the first 20-40 seconds then calmed down. Seemed to surge more than before, but I'll let you know driving data logs later tonight.
 

Attachments

  • Sponsors (?)

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
So I got the new one loaded and data logged a startup idle to the driveway to wash it. I'm taking it out later to a get together and will data log that as well. The startup had some popping (backfiring, popping in exhaust) in the first 20-40 seconds then calmed down. Seemed to surge more than before, but I'll let you know driving data logs later tonight.
what wideband are you using? and when you say backfire was it loud or more of a gurgle?
 

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
So I got the new one loaded and data logged a startup idle to the driveway to wash it. I'm taking it out later to a get together and will data log that as well. The startup had some popping (backfiring, popping in exhaust) in the first 20-40 seconds then calmed down. Seemed to surge more than before, but I'll let you know driving data logs later tonight.
I made some small changes to the idle control and added a small amount of fuel to the startup... keep me informed about that odd backfire at idle when at cold start.
you have been through and checked the timing offset on this engine before correct?
 

Attachments

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
It's the LC2 wideband, and the backfire is in the exhaust, more like an afterfire. It's fairly loud, and popping that sounds like it's lighting off in the exhaust pipes or when the exhaust valves are open. I'm 99.9% sure my timing is set properly and I posted a video in this thread (I think, or in my build thread) where I set the timing... either way, here's the video.

 

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Oh, and my accufab throttle body and new IAC are going to be here tomorrow to rule out those as an idle issue, plus it should be a welcome upgrade either way.
 

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Attached are the logs from the drive to the meet and then again on the way home. Nothing big to report, still some surging during warm up and at stop lights but not horrible. The 2nd one has some 2nd/3rd gear short pulls at the end of it but I was on city roads near home so nothing too big.
 

Attachments

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
Attached are the logs from the drive to the meet and then again on the way home. Nothing big to report, still some surging during warm up and at stop lights but not horrible. The 2nd one has some 2nd/3rd gear short pulls at the end of it but I was on city roads near home so nothing too big.
Was this with rev1.4?
 

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
Yes, the latest one your provided.
We are making progress, with the new iac in place the idle gain may change a bit but hopefully not much.
The changes i made... decreased idle valve gain, changed AFR table values to enrichen idle fuel, tuned the ve table further[ we are really close to having this complete for the most part], made minor change to idle timing increasing it to cool the headers this should* stop the afterfire. Please provide further feedback from a drivers perspective, throttle response power ect i cant tell these things from a datalog... also have a great weekend!
 

Attachments

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Thanks Steve, I got 1.5 loaded and started it up and let it idle until about 165 temp or so. First thing I noticed was that while it still surged it felt a lot smoother with less distance between the peaks and valleys of the surges. I grabbed a log, but I'll wait until after I get my new throttle body and IAC installed to take another one and make sure they aren't part of the issue as I don't want you chasing a hardware problem in the tune. They are supposed to arrive this afternoon so I should have it installed by this evening.

Unfortunately I noticed a small power steering leak after my drive last night so I won't be driving it a ton until my new parts arrive (new rack, pump, etc.) likely next week since I just ordered them this morning. I'll drive it some as it's all getting replaced, but I'll have to take it easy and keep an eye on the fluid levels.
 

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Ok, got the new TB on but haven't driven it yet. The first data log I forgot to calibrate the new TPS settings since I replaced the TB so the idle never came down as it thought it was at like 5% open TPS. I shut it down and calibrated it, then started it back up and let it idle and it's in the right RPM range but lots of surging. That said I can already tell the new TB gives it much better throttle response and it's not trying to stick closed like the old stock one did. New steering parts will be here next week so not a lot of driving till then as the pump is louder than the car.
 

Attachments

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
Ok, got the new TB on but haven't driven it yet. The first data log I forgot to calibrate the new TPS settings since I replaced the TB so the idle never came down as it thought it was at like 5% open TPS. I shut it down and calibrated it, then started it back up and let it idle and it's in the right RPM range but lots of surging. That said I can already tell the new TB gives it much better throttle response and it's not trying to stick closed like the old stock one did. New steering parts will be here next week so not a lot of driving till then as the pump is louder than the car.
Let me know when your car is road worthy again, i will do an update for you then.
 
Feb 6, 2012
79
5
18
50
@[email protected] how is the car coming along? haven't heard from you in awhile.
gotcha I will try and tune it down as close to stock idle as possible, however, there will always be a small amount of oscillation in the idle.
We left off here.Awaiting your instructions. I thought you were going to send another tune. I don't move until you tell me too. LOL. Been patiently waiting. In no rush. The car has only been sitting since 2014. Lol
 

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
We left off here.Awaiting your instructions. I thought you were going to send another tune. I don't move until you tell me too. LOL. Been patiently waiting. In no rush. The car has only been sitting since 2014. Lol
ohhh.... lol well i will get back to you a bit later, i think the last thing i did was send a tune right? if so i need a datalog from it.
 

bird_dog0347

I really enjoyed seeing your rear end up close
5 Year Member
Jun 7, 2012
824
698
134
38
Little Elm, TX
Let me know when your car is road worthy again, i will do an update for you then.
Thanks Steve, I got the cobra rack, taurus tie rod ends, and new (reman) pump delivered yesterday... MM steering shaft is scheduled to be delivered tomorrow. I'll grab hoses and fluid locally hopefully soon. I'm gonna try to get out there tonight to work on it but been dealing with a kid who can't get his crap together homework wise so that's what I do weekday evenings. I hope to have it back on the road in the next week or so, but already have a very full weekend planned as well. That said, I'm excited to drive it so I've got a decent level of motivation right now. I really apprecaite all your help Steve, I owe you some beers for sure!
 

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
I see you have to keep your foot on the throttle to make it run during warmup. Hopefully this tune will fix that, i increased the idle timing but the way i have it written the idle timing will not engage unless the TPS is below 2%..
The surge is not the idle valve i have it set so it will move to a set position based on coolant temp, rule that out we have fuel and timing. im thinking this increase in timing will help.
 

Attachments

Feb 6, 2012
79
5
18
50
I see you have to keep your foot on the throttle to make it run during warmup. Hopefully this tune will fix that, i increased the idle timing but the way i have it written the idle timing will not engage unless the TPS is below 2%..
The surge is not the idle valve i have it set so it will move to a set position based on coolant temp, rule that out we have fuel and timing. im thinking this increase in timing will help.
Still had to apply some throttle during and after start for a few of minutes. After car warmed up some surging decreased. Getting some backfiring over 4 grand RPM.
 

Attachments

a91what

Blower pulley, guide plates, spark plug bolts
Mod Dude
Apr 6, 2011
6,314
3,776
204
29
Hillsborough county
Still had to apply some throttle during and after start for a few of minutes. After car warmed up some surging decreased. Getting some backfiring over 4 grand RPM.
With this tune once the car is warm unplug the iac valve and set the base idle as low as you can without the car stalling. i want to see if unplugging the iac stops the surging.
 

Attachments