stupid question

BLKNED

Member
Jan 27, 2008
67
1
9
I just changed the tune in my car and can't get the tuner disconnected.:shrug: Is there a clip I am missing? I haven't had this problem before. I didn't want to just yank on it because I have a reputation for breaking things when I do that. Thanks.
 
  • Sponsors(?)


rugedraw

New Member
Oct 12, 2004
47
0
0
Miami, FL
You mean the actual plug that you connect to under the dash is stuck? Well, there are no clips that attach it. If it's stuck, the only thing you can do is yank it out. Just don't pull the cord. Try and find some large pliers, grab it, and gently pull on it in different directions to loosen it. I really can't think of anything else to do in this case. Weird.......
 

BLKNED

Member
Jan 27, 2008
67
1
9
Thanks guys. Like I said, it's never gotten stuck before. Just didn't wanna break anything. Guess I'll just work it out.
 

Lennyvb

Member
Feb 23, 2008
57
1
9
Centerport, NY
Thanks guys. Like I said, it's never gotten stuck before. Just didn't wanna break anything. Guess I'll just work it out.

I assume you have the SCT. I just looked at mine - on the underside of the plug there is a tab but I don't think it hooks to anything - you may want to squeeze it and see if that helps. When I first used mine, I pushed the plug all the way on and had the same difficulty removing it. Now, whenever I change my tune, I only put the plug about half way on - just enough to make a good connection. Comes off easy that way.
 

BLKNED

Member
Jan 27, 2008
67
1
9
Looks like a bullitt grill on your car . Great look. Real sleeper.

Thanks man, that's kinda what I am going for. Thinking about putting the v-6 pony badges on in place of the gt badges to add to that.

And yes, SCT. I went back out and pulled on the plug while pushing the dash up around the plug and it came right out.