Theft Light Rapidly Blinking. Car Does Start.

Discussion in '1996 - 2004 SN95 Mustang -General/Talk-' started by JodiStang, Jan 12, 2018.

  1. Guys,

    New here. Ireland-born, but living in Louisiana. Bought an '03 V6 Mustang as my first car a couple of years back.

    Noticed tonight (although perhaps it's been happening for a while) that my theft light is rapidly blinking (more than the once every 2 seconds it's supposed to) when the car is turned off. The car starts with no problems and the light goes out.

    Is this something to be concerned about? If so, where should I start looking? Could a problematic fuse do something like this?

    As for any possible recent repairs that might have impacted this: had a new alternator put in a few weeks back after mine failed in the middle of the night in the middle of nowhere in Tennessee.

    Nice to meet you all.

    Jodi
     
  2. Do you really know the history of this car? For example it's possible to disable PATS via a tune. But if done the Theft light will still flash because as far as the cluster is concerned the PATS key in not acceptable.
     
  3. Wm, I'm wondering if (because of the cold we're having here in Louisiana) it's due to a failing capacitor on the instrument panel itself. The light was fully on this morning (goes off when I start the car), then flashing rapidly again tonight. So it's inconsistent. My main worry is how much of a battery drain could this be? Anybody have any ideas?
     
  4. Thank you so much for your help (really do appreciate you putting my mind at ease). I just am spooked after getting stranded in the middle of the night with that alternator failure, and I'd replaced the battery earlier this Summer, so it's just got me paranoid. I will absolutely take a look at getting the scanner - I'm trying to learn because I love this car.