Will not start after battery charge

Discussion in 'SVT Tech Forum' started by yello9fo2g, Dec 28, 2010.

  1. I have a 2001 Mustang SVT Cobra that is driven very little (8,000 Miles). The battery went completely dead so I charged it up. Now it will turn over very fast but will not start. All the presets on the radio have been lost so I know the battery was completely flat. The "THEFT" warning light on the dash is constantly flashing. Can any one give me a hint on how to reset whatever to get the car started?
    Thanks, Terry
  2. Sounds like your PATS might be acting up, but I would doublecheck your battery and grounds before diving into the PATS system.

    First, check and re-check all of your major ground connections (including the ground strap by the driver's side of the engine, low to the ground) to make sure they are solid.

    Also, how old is your battery? Factory original? Or a 3 or 4 year replacement battery? :shrug: Check the "built-on" date stamped and/or affixed to the battery case.

    Have you tried load/bench testing the battery at an auto parts store? IIRC, Autozone and most other car part shops will test batteries for free.

    Have you tried using a volt-meter to get a readout of the battery's voltage? If the battery is older and was completely discharged, it might not be able to fully recover, so it might be rendered useless.

    FWIW - Probably not a bad idea to invest a few bucks in a battery tender - they are great little gadgets for seldom driven toys parked in the garage...

    G'luck! :cheers:
  3. FWIIW, the later model year PATS system is "tripped" by disconnecting the battery. Try opening the driver's door with the key or using the lock and un-lock button on the remote FOB to reset.

    To test if the fix worked, turn the iginition key on but do not crank. Verify that the theft light goes out after a 3 second "prove out". If not, STOP and find out why.

    Now crank the motor. Does the theft light come on? If so, STOP and find out why.
  4. This may sound like a stupid suggestion, but make sure you unlock your steering wheel if it is in the locked position. I've done this before and it wouldn't crank :notnice:
  5. Thanks for all your suggestions. As it turns out the engine wasn't getting any fuel and I did not hear the fuel pump running. Slapping the fuel tank started the pump but it would not keep running once the engine started. Also the engine was running rough like it was starving for fuel so I am pulling the tank and changing the very expensive pump. I prefer to work on my Boss 302 than these modern cars!
    Thanks, Terry

  6. Tip:

    While you have the fuel tank dropped, take a moment to swap out the fuel filter - it's tucked up there in a pretty tight spot and with the fuel tank removed, it is MUCH easier to reach up and replace the fuel filter.

    Changing the fuel filter can certainly be done with the tank still in place, but with the tank removed, it makes the job SO much easier! :nice:

  7. Hope im not too late but... but theres that switch in the trunk to deactivate the fuel pump relay. Have you checked that?

    I dont have my manual handy, but isnt there a fuse/relay for the pump?

    Trying to think of the smaller (cheaper) fixes before dropping the entire tank... oof