1975 Carb problem---question

Discussion in '1974 - 1978 Mustang II Talk & Tech' started by eaglecap, May 25, 2005.

  1. eaglecap

    eaglecap Member

    Joined:
    Jul 31, 2000
    Messages:
    66
    Likes Received:
    0
    Trophy Points:
    7
    I just finished a total rebuild on my V6 and am having problems getting the carb adjusted correctly. Runs a little rough so you have to crank up the idle to about 900. Had a shop put it on a scope and do their thing. The mechanic told me the throttle plates were not closing all the way, and I would have to tear the carb down and figure out why. I just rebuilt the carb and every thing looked good and adjusted OK off the engine. But they are slightly open now. Anyone run into this problem?
     
    #1
  2. Addicted_2_II

    Addicted_2_II New Member

    Joined:
    Dec 29, 2003
    Messages:
    187
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Kansas City, MO
    Maybe your throttle cable is holding it open? Just a guess? Might unhook it and see.
    Chad
     
    #2
  3. 1970impala

    1970impala Please God, somebody find me some WHITE CARGO PANE
    Founding Member

    Joined:
    Jan 22, 2002
    Messages:
    1,450
    Likes Received:
    1
    Trophy Points:
    38
    Location:
    Pennsylvania
    hi, i have but with my camaro, not the stang. the problem was the choke flap. the choke flap or the body of the carb warped somehow and the choke flap was not free when it got to the closing. it was sticking and keeping the throttle body opened wider than supposed to. took off the flap and sanded the flap down, then rescrewed the flap back on. perfect now.
     
    #3

Share This Page