1. toadstang

    toadstang New Member

    Joined:
    Nov 16, 2003
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Newport News, VA
    Yay, it wasn't an oil leak. For the longest time I thought it was, but after closer observation, I found out it was simply a cracked radiator hose, which, when it dripped, and the fan cut on, it flew back onto the block instead of dripping down, so it made me think it was oil, but Imma get it all fixed today. :nice: Also explains why my car is heating up, so I fix two problems at once.
  2. mr_woodster

    mr_woodster Active Member

    Joined:
    Jul 28, 2003
    Messages:
    1,316
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Riverside, CA
    too bad your cars not a turbocoupe i had a really good pun...

    kill to birds with one stone ;)

    anyways good job...lucky you!
  3. 351wcoupe

    351wcoupe New Member

    Joined:
    Feb 13, 2003
    Messages:
    1,845
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Manhattan, Kansas

    WAIT A MINUTE!!
    Let me get this straight...







    Your fan works? Is that original? I didn't think they worked from the factory.
  4. mr_woodster

    mr_woodster Active Member

    Joined:
    Jul 28, 2003
    Messages:
    1,316
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Riverside, CA
    :rlaugh: :lol:
  5. toadstang

    toadstang New Member

    Joined:
    Nov 16, 2003
    Messages:
    79
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Newport News, VA
    Yes it works MUVU*** :D

Share This Page