Windows Wont Go Up?

Discussion in '2.3L (N/A & Turbo) Tech' started by MyCARneedsHelp, Jun 21, 2005.

  1. Hey guys.
    I finally started to rip the 5.0 apart after the accident and i was taking the windows out for my 2.3. Well i got in the 2.3 and the windows were fine yesterday and now all of a sudden they wont go up.I didnt change them yet becuz i cant get them up. I checked my fuses and they are fine but im not sure how to test the relay in there. It seems to be getting REALLY hot, and when i turn the key it sounds like somthing isnt right. The fuel pump jumps a little instead of the solid sound they normally make. It starts fine. It sounds like its coming from that lil relay in the fuse panel. Sounds like electricity is bouncing around in there. When i turn the key to the on pos. i hear it. Its really weird. I dunno, Been having real bad luck with mustangs latley....:nonono:
     
  2. Okay i checked it out some more. When i pull the relay out the fuel pump and everything in the fuse panel sounds fine. When i put the new one, or old one in- i hear some clicking and the fuel pump sounds like its getting choppy???. Anything else i should check out?
     
  3. A little off topic, but glad to see your recovered, I was off the internet for a couple months after I moved so I missed a lot!
    I have had problems with my power window motors, but mine were solved by rebuilding the motors, not at all the situation your dealing with...
     
  4. does your pump sound horrid when it starts up? Or has it been pretty loud just normaly working it the past wile its been driven? Ive had that happen were my pump was just fried and sucking alot of power. Best of luck with your problem:)
     
  5. the fuel pump is good, its my windows that arent working. The pump makes a weird noise when the window relay is in.